[System] UI resizes failed in case: FTU meets keyboard and window.open

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: alive, Assigned: alive)

Tracking

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

STR:

1. Flash the phone
2. Goto the step: Import contacts
3. Click import from facebook
4. Click email field to let keyboard show.

Expected:
1. UI works.

Actual:
1. UI has 20pixel distance from bottom, and never back to correct position even if the keyboard is hidden.

Note:
This is a bug in window manager resize function.
OOPS, it seems not relavant to keyboard. window.open just not working in fullscreen mode. SAD.
I think I saw a dupe of this bug with exactly what's described in comment 1 with "window.open" and "fullscreen"
Whiteboard: DUPEME
blocking-basecamp: --- → ?
QA Contact: jsmith
Duplicate of this bug: 811071
blocking-basecamp: ? → +
Priority: -- → P2
Whiteboard: DUPEME
Assignee: nobody → fbsc
Reassign to myself because I am the owner of system app resize function, welcome to take if anyone wants.
Assignee: fbsc → alive

Comment 5

6 years ago
Can you attach a screenshot?
Priority: P2 → P3
Target Milestone: --- → B2G C3 (12dec-1jan)
https://github.com/alivedise/gaia/commit/f1b0eb281c85eb139fceaf6b33f2445e135d8968 also resolves this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 687598 [details]
screenshot of leaking height
You need to log in before you can comment on or make changes to this bug.