Closed Bug 810765 Opened 8 years ago Closed 8 years ago

B2G Desktop doesn't redraw properly

Categories

(Core :: Web Painting, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 799768

People

(Reporter: dhylands, Unassigned)

Details

Attachments

(1 file)

I built a copy of B2G desktop using gaia/master and git://github.com/mozilla/releases-mozilla-central

After launching, if I click, slide, release, I discovered I had to click one more time to get the screen to redraw.

This didn't just happen in the homescreen. I also got the behaviour in the apps as well.

In The settings app I observed that for every action that involved a mouse click, I had to click one more time to get a screen redraw.

I'm retesting with mozilla-aurora to see if there are any differences.
I see the same behaviour on m-a with gaia/master gaia/nightly

I'm running Linux Mint 13 (Ubuntu 12.04 derivative)
This patch from cjones fixes the issue for me. I could not find if Chris was working on this in another bug and if yes in which one.
I can confirm that the patch fixes the issue I was seeing
Component: Gaia → Layout: View Rendering
Product: Boot2Gecko → Core
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799768
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.