"Show all downloads" doesn't actually show all downloads

RESOLVED DUPLICATE of bug 675902

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 675902
5 years ago
5 years ago

People

(Reporter: Timvde, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121111030749

Steps to reproduce:

In the new download panel, click "Show all downloads"


Actual results:

It opened the download manager, but with only the downloads of the current session listed


Expected results:

All my downloads should've been there.

Users of the new panel don't have a proper way to manage their downloads, as the library isn't really appropriate for that (it's just a list of web links) and is hard to discover.

The new panel is useful by itself, and should be cleared every session for overview's sake. But this should not affect the separate, old download window.
Component: Untriaged → Downloads Panel

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675902
You need to log in before you can comment on or make changes to this bug.