Closed Bug 810795 Opened 7 years ago Closed 7 years ago

Website HTTPS dropped session not reset to http

Categories

(Firefox :: Untriaged, defect)

16 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 769994

People

(Reporter: chihwahli, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

I log into a HTTPS site www.werk.nl. Then I usually do not log off. 
I will turn windows 7 into hibernation mode. 


Actual results:

The next time I type into the browser : "www.werk.nl". Firefox opens the https website instead, resulting in an error.The werk.nl server returns an error ofcourse, because the session is already due.



Expected results:


Can't Firefox determine that the session is over and drop the https session?
And just open the http website : www.werk.nl ?

The only way I can fix this is too throw away my history, cookies ,etc
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
It's not resolved. I am experiencing this behavior every time.
And I do not experience this with other https websites.
This is a really strange default behavior that Firefox implemented. Could someone give a simple way to change this behavior?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to chihwahli from comment #2)
> It's not resolved. I am experiencing this behavior every time.
> And I do not experience this with other https websites.

It's resolved as a duplicate, but bug 769994 is still open.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
The workaround is to type an additional space after the desired URL.
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.