If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] alt+d should give focus to URL bar

VERIFIED DUPLICATE of bug 19446

Status

SeaMonkey
Location Bar
--
enhancement
VERIFIED DUPLICATE of bug 19446
17 years ago
9 years ago

People

(Reporter: Chad Austin, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Just like IE and K-Meleon do, pressing ALT+D in any browser window should give 
focus to the URL bar and select all of its text.


Reproducible: Always
Steps to Reproduce:
1. open any browser window
2. press ALT+D


Actual Results:  nothing

Expected Results:  Keyboard focus should be given to the URL bar and all of the 
text should be selected.

Comment 1

17 years ago
control-l currently does this. I don't think we need another key.
Assignee: asa → alecf
Component: Browser-General → URL Bar
QA Contact: doronr → claudius
(Reporter)

Comment 2

17 years ago
Why was CTRL+L chosen instead of ALT+D (already an arguably de facto standard)? 
 I don't know what the browsers on Mac/Linux use.
Because Alt-whatever should not execute an action.  It should open a menu...

NS 4.x on linux has no keybinding to focus the URL bar, fwiw.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
Boris: Okay, I agree with you there.  Feel free to mark this is invalid.  Or a 
duplicate of bug 19446?
I think marking this duplicate is the way to go...  Though I definitely see why
people would want alt+D to do this, that's also being discussed in bug 19446

*** This bug has been marked as a duplicate of 19446 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.