Errors when searching for addons in the addon manager

RESOLVED DUPLICATE of bug 769483

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 769483
5 years ago
5 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Timestamp: 11/13/12 2:46:09 AM
Error: An exception occurred.
Traceback (most recent call last):
  File "resource://gre/modules/XPIProviderUtils.js", line 177, in 
    this.callback(this.addons);
  File "resource:///modules/XPIProvider.jsm", line 3186, in 
    aCallback([createWrapper(a) for each (a in aAddons)]);
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 179, in AOC_callNext
    this.listener.nextObject(this, object);
  File "resource://gre/modules/AddonManager.jsm", line 1653, in 
    function(aProviderAddons) {
  File "resource://gre/modules/AddonManager.jsm", line 104, in callProvider
    return aProvider[aMethod].apply(aProvider, aArgs);
  File "resource://gre/modules/LightweightThemeManager.jsm", line 378, in 
    aCallback([new AddonWrapper(a) for each (a in this.usedThemes)]);
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 179, in AOC_callNext
    this.listener.nextObject(this, object);
  File "resource://gre/modules/AddonManager.jsm", line 1653, in 
    function(aProviderAddons) {
  File "resource://gre/modules/AddonManager.jsm", line 104, in callProvider
    return aProvider[aMethod].apply(aProvider, aArgs);
  File "resource:///modules/PluginProvider.jsm", line 111, in PL_getAddonsByTypes
    aCallback(results);
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 179, in AOC_callNext
    this.listener.nextObject(this, object);
  File "resource://gre/modules/AddonManager.jsm", line 1653, in 
    function(aProviderAddons) {
  File "resource://gre/modules/AddonManager.jsm", line 104, in callProvider
    return aProvider[aMethod].apply(aProvider, aArgs);
  File "jar:file:///Users/evold/Library/Application%20Support/Firefox/Profiles/uaavovcz.erikvvold@gmail.com/extensions/%7B46551EC9-40F0-4e47-8E18-8E5CF550CFB8%7D.xpi!/components/stylishStartup.js", line 52, in 
    aCallback(styles.map(getUserStyleWrapper));
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 179, in AOC_callNext
    this.listener.nextObject(this, object);
  File "resource://gre/modules/AddonManager.jsm", line 1653, in 
    function(aProviderAddons) {
  File "resource://gre/modules/AddonManager.jsm", line 104, in callProvider
    return aProvider[aMethod].apply(aProvider, aArgs);
  File "resource://scriptish/addonprovider.js", line 123, in 
    aCallback(Scriptish_config.scripts);
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 179, in AOC_callNext
    this.listener.nextObject(this, object);
  File "resource://gre/modules/AddonManager.jsm", line 1653, in 
    function(aProviderAddons) {
  File "resource://gre/modules/AddonManager.jsm", line 104, in callProvider
    return aProvider[aMethod].apply(aProvider, aArgs);
  File "resource://searchengine-manager-at-erikvold-dot-com/addonprovider/lib/addonprovider.js", line 60, in 
    aCallback(options.getAddons());
  File "resource://gre/modules/AddonManager.jsm", line 1655, in 
    aCaller.callNext();
  File "resource://gre/modules/AddonManager.jsm", line 173, in AOC_callNext
    this.listener.noMoreObjects(this);
  File "resource://gre/modules/AddonManager.jsm", line 1660, in 
    safeCall(aCallback, addons);
  File "resource://gre/modules/AddonManager.jsm", line 78, in safeCall
    aCallback.apply(null, aArgs);
  File "resource:///modules/AddonRepository.jsm", line 1398, in 
    aCallback(localAddonIds);
  File "resource:///modules/AddonRepository.jsm", line 877, in 
    self._parseAddons(aElements, aTotalResults, aLocalAddonIds);
  File "resource:///modules/AddonRepository.jsm", line 1198, in 
    let result = this._parseAddon(element, aSkip);
  File "resource:///modules/AddonRepository.jsm", line 987, in 
    addon[HTML_KEY_MAP[localName]] = convertHTMLToPlainText(this._getTextContent(node));
  File "resource:///modules/AddonRepository.jsm", line 106, in convertHTMLToPlainText
    output, {});
  File "resource://view_source_in_tab-at-erikvold-dot-com/api-utils/lib/system/events.js", line 58, in 
    data: data
  File "resource://view_source_in_tab-at-erikvold-dot-com/api-utils/lib/l10n/html.js", line 50, in onContentWindow
    if (document.location.href.indexOf(assetsURI) !== 0)
TypeError: document.location is null
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769483
You need to log in before you can comment on or make changes to this bug.