netwerk/protocol/http/SpdySession3.cpp>:1873:20: error: expected a class or namespace

RESOLVED DUPLICATE of bug 811214

Status

()

RESOLVED DUPLICATE of bug 811214
6 years ago
6 years ago

People

(Reporter: gps, Assigned: espindola)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
My personal daily LLVM/Clang tip + m-c builds have failed two days with the following error:

ASpdySession.cpp
SpdySession2.cpp
SpdyStream2.cpp
SpdySession3.cpp
SpdyStream3.cpp
ConnectionDiagnostics.cpp
nsIHttpActivityObserver.idl
<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/netwerk/protocol/http/SpdySession3.cpp>:1873:20: error: expected a class or namespace
    GenerateGoAway(goawayReason::OK);
                   ^
nsIHttpAuthManager.idl
nsIHttpAuthenticator.idl
1 error generated.

In the directory  <http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/obj/netwerk/protocol/http>
The following command failed to execute properly:
/home/jenkins-slave/workspace/llvm/bin/clang++ -o SpdySession3.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include <http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/config/gcc_hidden.h> -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES -DOS_POSIX=1 -DOS_LINUX=1 -DIMPL_NS_NET -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/netwerk/protocol/http/../../base/src> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/xpcom/ds> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/content/base/src> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/content/events/src> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/ipc/chromium/src> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/ipc/glue> -I../../../ipc/ipdl/_ipdlheaders -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/netwerk/protocol/http> -I. -I../../../dist/include -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/obj/dist/include/nspr> -I<http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/obj/dist/include/nss> -fPIC -Qunused-arguments -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-mismatched-tags -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer -Qunused-arguments -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/SpdySession3.o.pp <http://jenkins.gregoryszorc.com:9000/job/mozilla-central-linux-x64-optimized-llvm-tip/ws/netwerk/protocol/http/SpdySession3.cpp>
make[7]: *** [SpdySession3.o] Error 1
make[7]: *** Waiting for unfinished jobs....
nsViewSourceHandler.cpp
nsViewSourceChannel.cpp
WebSocketChannel.cpp
WebSocketChannelParent.cpp
WebSocketChannelChild.cpp
make[6]: *** [http_libs] Error 2
make[6]: *** Waiting for unfinished jobs....
nsIViewSourceChannel.idl
BaseWebSocketChannel.cpp
nsIWebSocketChannel.idl
nsIWebSocketListener.idl
make[5]: *** [protocol_libs] Error 2
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2


We're not seeing failures on the buildbot builds, so, something in Clang is different (it's possible it's a Clang regression). The failing file in m-c also changed a few days ago as part of bug 809909, bug 809913, and bug 810152. So, it's possible one of those changes triggered this. I haven't dug into this at all, so I'm not sure who to blame here.
llvm 3.2 just branched. I will try to update to it today or tomorrow to make sure we get a llvm/clang release that works for us. This bug is hopefully a subset of that.
Assignee: nobody → respindola
Status: NEW → ASSIGNED
Looks like the build with the 3.2 branch is not hitting this bug:

https://tbpl.mozilla.org/?tree=Try&rev=021846b78bd8

Can you attached the preprocessed SpdySession3.ii? Is this on OS X or Linux. Which clang revision, mozilla revision and libstdc++ version are you using?
(Reporter)

Comment 3

6 years ago
LLVM: 167720 (last good was 167674)
m-c: https://hg.mozilla.org/mozilla-central/rev/b2bdbfe06b10 (bisect range is https://hg.mozilla.org/mozilla-central/rev/a47525b93528 (good) to https://hg.mozilla.org/mozilla-central/rev/cf7575ceef5a (bad)

libstdc++: 4.7.2-2ubuntu1
(Reporter)

Comment 4

6 years ago
Created attachment 680928 [details]
SpdySession3.ii

Here is the clang++ -E output.

 /home/jenkins-slave/workspace/llvm/bin/clang++ -o SpdySession3.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DSTATIC_EXPORTABLE_JS_API -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES  -DOS_POSIX=1 -DOS_LINUX=1  -DIMPL_NS_NET -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/netwerk/protocol/http/../../base/src -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/xpcom/ds -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/content/base/src -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/content/events/src  -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/ipc/chromium/src -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/ipc/glue -I../../../ipc/ipdl/_ipdlheaders  -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/netwerk/protocol/http -I. -I../../../dist/include  -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/obj/dist/include/nspr -I/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/obj/dist/include/nss      -fPIC -Qunused-arguments  -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-mismatched-tags -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fshort-wchar -pthread -pipe -DDEBUG -D_DEBUG -DTRACING -g -fno-omit-frame-pointer    -Qunused-arguments  -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/SpdySession3.o.pp  /home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/netwerk/protocol/http/SpdySession3.cpp
/home/jenkins-slave/workspace/mozilla-central-linux-x64-debug-llvm-tip/netwerk/protocol/http/SpdySession3.cpp:1873:20: error: expected a class or namespace
    GenerateGoAway(goawayReason::OK);

LLVM r167808 and https://hg.mozilla.org/mozilla-central/rev/b857905d82b4
Duplicate of this bug: 811214
Duplicating the other way around, since the other bug has a patch.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811214
You need to log in before you can comment on or make changes to this bug.