Proxy: FTP does not show username+password dialog (when proxy sends 401)

VERIFIED FIXED in mozilla0.9.3

Status

()

--
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: benc, Assigned: dougt)

Tracking

({testcase})

Trunk
mozilla0.9.3
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
STEPS:

1- Configure for manual, FTP proxy.
2- Use a URL that has a user, but no password (ftp://test@packetgram.com/)

OBSERVED BEHAVIOR:
No page is loaded, no error is displayed, no auth is displayed.
Console does show:
"Error loading URL ftp://test@packetgram.com/ : 2147500037"

EXPECTED BEHAVIOR:
Set manual proxy to "direct" and send URL again to see normal behavior.
An auth dialog box should appear asking for a password.

ANALYSIS:
Similar to bug 52615, a 4xx HTTP response from the proxy is not being handled.

If you use a FTP URL that has the username and password embedded, then the ftp
request is displayed (since there is no 401 event to be handled).

In this case, the proxy has tried to use the username to connect to the ftp
server, and received a password request. The proxy uses the existing HTTP
mechanisms to request the password by returning a  401 to the client, which is
dropped.

The proxy log shows this, for example:

208.12.40.178 - - [15/May/2001:17:57:09 -0700] "GET
ftp://benc@frame.packetgram.com/ HTTP/1.1" 401 306 - - - - 320 144 - - 1 DIRECT
FIN - DO-NOT-CACHE
2
You can see the "401" status returned. If the client had returned a password
that was forwarded to the ftp server and accepted, the Proxy would have logged a
"200" for the transaction (Netscape Proxy Server globs up successful auth
challenges into a single log entry).

Comment 1

18 years ago
-->ftp
Assignee: neeti → dougt
Component: Networking → Networking: FTP

Updated

18 years ago
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 2

18 years ago
mass setting milestone.  if this is something you believe is more urgent then 
the milestone that I just sent, please send me mail.
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 3

18 years ago
I believe that this should be fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
qa -> benc for verification
QA Contact: tever → benc
(Reporter)

Comment 5

17 years ago
VERIFIED: Mozilla 1.0, Win98

if you use a url w/ a username, the username doesn't appear in the auth dialog box.

Comm 4 does this, so I've created a 4xp report in bug 149103.
Status: RESOLVED → VERIFIED
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.