--filter option of PerfConfigurator needs better documentation.

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: nebelhom, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121025210744

Steps to reproduce:

There is no description on how to use the --filter option in PerfConfigurator in the documentation anywhere. The --help doc is not very helpful, either. Maybe add an example on how to use several filters in one call.

There is also a difference between series and scalar filters. The last mentioned filter has to be a scalar filter and the other ones before all have to be series filters. This is also not mentioned anywhere.

Comment 1

6 years ago
This probably belongs in the wiki or README since filters are complicated.  In the long term, we want to eliminate filters and graphserver altogether.  I would vote for the wiki: the README is heavily outdated and quite frankly I'd rather delete it and start again when convenient vs try to rescue it at this point
Status: UNCONFIRMED → NEW
Ever confirmed: true
The filter option has been removed with bug 1191796.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.