Closed Bug 811178 Opened 9 years ago Closed 9 years ago

3rd party app SpaceWorm doesn't respond to taps

Categories

(Firefox OS Graveyard :: General, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

RESOLVED FIXED
B2G C2 (20nov-10dec)
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: adora, Assigned: mwu)

Details

Attachments

(1 file)

In this game, the worm should follow where you tap.  On Firefox OS, the worm doesn't respond to taps at all.  Works fine on Android (Galaxy Nexus) and Desktop.

Marketplace link:  https://marketplace.mozilla.org/app/spaceworm/
Confirmed also. Also seeing flickering going on here.
blocking-basecamp: --- → ?
This sounds a lot like the touch issue in bug 811198.

We already have a pile of bugs on the image flickering issue. cc'ing Justin so he's aware that we have yet more dups of that one.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811198
This app is listed as under review. I'd like to test it.
(In reply to Michael Wu [:mwu] from comment #3)
> This app is listed as under review. I'd like to test it.

You could install the app directly by calling navigator.mozApps.install with this manifest:

http://subspaceworm.dseffects.com/SpaceWorm.webapp
This game suffers from the same useragent detection issue I mentioned in bug 811198.
I guess this bug is invalid then - it's a developer problem.
Resolution: DUPLICATE → INVALID
I'm going to steal this bug to improve our compatibility with things expecting mouse events. It makes this game playable if you stick to taps.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Okay. I'll send this back into triage though to see if it still blocks.
blocking-basecamp: + → ?
Assignee: nobody → mwu
This patch sends a mousemove before mousedown and mouseup so apps like these can sort of limp along. This matches what we do with Firefox on Android - http://hg.mozilla.org/mozilla-central/file/e8f0504ccbb9/mobile/android/chrome/content/browser.js#l3842 .
Attachment #688498 - Flags: review?(jones.chris.g)
blocking-basecamp: ? → +
Can we get a priority and target milestone for this>
Priority: -- → P3
Target Milestone: --- → B2G C2 (20nov-10dec)
Attachment #688498 - Flags: review?(jones.chris.g) → review+
https://hg.mozilla.org/mozilla-central/rev/3c88682ae393
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.