Closed Bug 811226 Opened 7 years ago Closed 7 years ago

"Assertion failure: Type() == eOnError"

Categories

(Core :: DOM: Events, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 811069

People

(Reporter: jruderman, Assigned: peterv)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Assertion failure: Type() == eOnError, at dom/base/nsIJSEventListener.h:116

This assertion is part of code added in bug 807226.
Attached file stack
I bet this is a duplicate of bug 811069.  The code in bug 807226 compiles the attribute to an EventHandlerNonNull, but then the code from bug 804950 tries to get it as an OnErrorEventHandlerNonNull.
Blocks: 804950
Depends on: 811069
I checked in the testcase:

https://hg.mozilla.org/integration/mozilla-inbound/rev/414ca3fc8e99
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → DUPLICATE
Duplicate of bug: 811069
You need to log in before you can comment on or make changes to this bug.