Remove leading zeros from Clocks when in 12 hr mode.

RESOLVED DUPLICATE of bug 805615

Status

P3
normal
RESOLVED DUPLICATE of bug 805615
6 years ago
6 years ago

People

(Reporter: jcarpenter, Unassigned)

Tracking

({polish})

unspecified
x86
Mac OS X
polish

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: interaction)

(Reporter)

Description

6 years ago
When system time format is set to 12 hr, clocks should not display leading zeros. 

* 06:45 AM — Wrong
* 6:45 AM — Right

This bug is seen most prominently in the Status Bar. 

This bug is necessitated by decisions made during SF work week (captured in "User story SET-157 - 12 vs 24hr time" email thread) to support both 12 and 24 hour time formats in v1.
blocking-basecamp: ? → -
Keywords: feature → polish
06:45 is also wrong in 24hr mode, right? So I think we always want to remove leading zeros from clocks.
(Reporter)

Updated

6 years ago
Blocks: 811242
I’d say 06:45 is correct in 24h mode but not in 12h mode. Is there some spec for that?
(Reporter)

Comment 3

6 years ago
(In reply to Tim Taubert [:ttaubert] from comment #1)
> 06:45 is also wrong in 24hr mode, right? So I think we always want to remove
> leading zeros from clocks.

A quick bit of research indicates that a leading zero in a 24hr clock is fine.
Priority: -- → P3
Whiteboard: interaction
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805615
You need to log in before you can comment on or make changes to this bug.