Tab menu background color changes to black on gingerbread devices

VERIFIED FIXED in Firefox 19

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: paul.feher, Assigned: sriram)

Tracking

({regression})

19 Branch
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19+ verified, firefox20 verified, fennec19+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Nightly 19.0a1 (2012-11-12)
Device: Samsung Galaxy R (Android 2.3.4), HTC Desire Z (Android 2.3.3)

Steps to reproduce:
1. Start firefox.
2. Open multiple tabs.
3. Open tab menu and scroll the list up and down.

Expected result:
For the unselected tabs the background stays grey when scrolling.

Actual result:
For the unselected tabs the background changes from grey to black when scrolling.The issue is only reproducible for gingerbread devices.

NOTE: Please see the video.
http://youtu.be/QX5WS8FGnpc
Private video; can you post a screenshot and attach it to the bug for reference.

Also; is this a regression?
tracking-fennec: --- → ?
Over 200 changes in that range; would need Tinderbox inbound builds to narrow it down.

I do see bug 783092 in that range, and if I had to guess I would put my chips on that.
Assignee: nobody → sriram

Comment 5

7 years ago
I stared working on finding the regression in inbound, I will finish it first thing in the morning.

Comment 6

7 years ago
(In reply to Aaron Train [:aaronmt] from comment #3)
> Over 200 changes in that range; would need Tinderbox inbound builds to
> narrow it down.
> 
> I do see bug 783092 in that range, and if I had to guess I would put my
> chips on that.

Looks like your guess was correct. According to tinderbox inbound builds the bug is somewhere here:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=24d449c76fe6&tochange=7599929c5258
(Assignee)

Comment 7

7 years ago
Is the one shown in the video is a samsung device? I suspect them using a scrolling cache color as black. This should be easy to fix.
tracking-fennec: ? → 19+
(Reporter)

Comment 8

7 years ago
(In reply to Sriram Ramasubramanian [:sriram] from comment #7)
> Is the one shown in the video is a samsung device? I suspect them using a
> scrolling cache color as black. This should be easy to fix.

Yes it is a Samsung galaxy R, but like i said on comment 0 the issue is reproducible for both Samsung galaxy R and HTC Desire Z devices.
Blocks: themes
(In reply to Andreea Pod from comment #9)
> http://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=24d449c76fe6&tochange=7599929c5258

Why did you remove the 19+ back to question?

Comment 11

7 years ago
(In reply to Aaron Train [:aaronmt] from comment #10)
> (In reply to Andreea Pod from comment #9)
> > http://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?fromchange=24d449c76fe6&tochange=7599929c5258
> 
> Why did you remove the 19+ back to question?

It was by mistake, sorry. Can you change it back, please, I don't have access to do that.
tracking-fennec: ? → ---
tracking-fennec: --- → 19+
sriram we're halfway into Aurora 19 cycle - can you provide an update on this bug's progress and options for fixing this regression?
Flags: needinfo?(sriram)
(Assignee)

Comment 13

7 years ago
Posted patch PatchSplinter Review
Done. :D
Attachment #689301 - Flags: review?(mark.finkle)
Flags: needinfo?(sriram)
Attachment #689301 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/27c4180188af
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
If this landed on central a week ago then we still need mozilla-aurora approval here to get this fixed on 19 - please nominate asap with a risk assessment.
(Assignee)

Comment 17

6 years ago
I just realized that this might affect the synced-tabs list too. Will post a patch for that.
(Assignee)

Comment 18

6 years ago
Comment on attachment 689301 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Personas support. Bug 783092
User impact if declined: Black background for listviews in pre-honeycomb phones.
Testing completed (on m-c, etc.): 12/07
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: None.
Attachment #689301 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 19

6 years ago
Posted patch Patch 2Splinter Review
A quick patch.
Attachment #693626 - Flags: review?(mark.finkle)
Attachment #693626 - Flags: review?(mark.finkle) → review+
Comment on attachment 689301 [details] [diff] [review]
Patch

Low risk theme fix - approving for Aurora 19.
Attachment #689301 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 23

6 years ago
Comment on attachment 693626 [details] [diff] [review]
Patch 2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Personas
User impact if declined: Synced tabs will have black background during scroll.
Testing completed (on m-c, etc.): Landed yesterday.
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: None.
Attachment #693626 - Flags: approval-mozilla-aurora?
Comment on attachment 693626 [details] [diff] [review]
Patch 2

Low risk persona's theme fix - approving for Aurora 19.
Attachment #693626 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The issue is no longer reproducible on Firefox Mobile 19 beta 1 and Aurora 20.0a2 2013-01-10 on the HTC Desire Z (Android 2.3.3). Marking as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.