[Status Bar] Hide status bar clock when device on lock screen

RESOLVED FIXED

Status

Firefox OS
Gaia::System
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jcarpenter, Assigned: ttaubert)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: visual design)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The Status Bar clock should be hidden when viewing the Lock screen, and reappear as soon as the user unlocks the device. This is because the v1 Lock screen design already incorporates a large clock, rendering the Status Bar clock redundant.
(Assignee)

Updated

6 years ago
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
Created attachment 682114 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6441

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #682114 - Flags: review?(timdream+bugs)
Comment on attachment 682114 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6441

\o/, love CSS!

I would worry that we are using setTimeout() to update an invisible clock, but that's minimal.
Attachment #682114 - Flags: review?(timdream+bugs) → review+
Josh, Please either seek a? or blocking? to get this merged, thanks.
(Reporter)

Comment 4

6 years ago
Comment on attachment 682114 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6441

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #682114 - Flags: approval-gaia-master?(21)
(Reporter)

Comment 5

6 years ago
Sorry for the blank fields. First time I've request merge approval.

* "Testing completed: " — I'll have to defer to Tim on this one.
* "User impact if declined: " — Lock screen clutter and duplication. Not end of world, but we'd like to fix this.
Comment on attachment 682114 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6441

Let's merge that to the UX branch of Gordon. This will take the UI/UX weekly train.

CC'ing gordon.
Attachment #682114 - Flags: approval-gaia-master?(21) → approval-gaia-master-
Gordon can you take that into your UX branch?
Priority: -- → P3
(Assignee)

Comment 8

6 years ago
Gordon, did this make it's way into the UX branch?
Blocks: 811242
This bug is blocking bug 811242 which is bb+. Merging.
https://github.com/mozilla-b2g/gaia/commit/cbfff95bd728387709d580bcd916fcda949062b2
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I suspect this caused bug 834542.
Depends on: 834542
So the status-bar clock is temporarily redundant, while we're at the at-rest lock screen. Is that really a big deal?

For comparison:
 a) The android lock screen shows the time in big numbers, while still keeping its status-bar clock visible.
 b) The Android and B2G "Clock" apps both shows the time in big numbers (or in an analog clock, your choice) while still keeping the status-bar clock visible.

So per (b), we're sort of internally inconsistent on this (or at least, we don't let the redundant-clock bother us in the Clock app, so I don't know why it'd bother us in the lock screen).

So: given that this wasn't a high-value change, and given that it caused regression bug 834542 (making us show *no* clock at all in some situations where we'd previously show a clock and where it might be crucial to know the time, e.g. in the emergency dialer), I'd argue we should either back out this bug or devote resources to fixing bug 834542.
(Reporter)

Comment 14

5 years ago
Commented in bug #811240.
(Reporter)

Comment 15

5 years ago
Typo on my part. Meant to say "commented in bug #834542"
You need to log in before you can comment on or make changes to this bug.