If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Bluetooth] can share files, but always shows "file transfer failed"

RESOLVED DUPLICATE of bug 811615

Status

Firefox OS
Gaia::Bluetooth
RESOLVED DUPLICATE of bug 811615
5 years ago
5 years ago

People

(Reporter: dkuo, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When using Gallery and Music, users can share files to paired devices, but always shows "Bluetooth file transfer failed"
(Reporter)

Comment 1

5 years ago
Related to bug #809781
(Reporter)

Updated

5 years ago
Assignee: dkuo → iliu
(Reporter)

Comment 2

5 years ago
The flow of how we share files via bluetooth in gaia:

- Gallery or Music (File) -web activity-> Bluetooth app (File) -> mozBluetooth (File)

But currently result in:

- Gallery or Music (File) -web activity-> Bluetooth app (Blob) -> mozBluetooth (Blob)

Looks like after passing by web activities, a File object will become a Blob object,
but mozBluetooth api needs File, not Blob object because it needs File.name and File.size
Blobs doesn't contain .name and .size

So that's why it always shows failed for current gaia.
(Assignee)

Updated

5 years ago
Depends on: 811615
(Reporter)

Comment 3

5 years ago
(In reply to Dominic Kuo [:dkuo] from comment #2)
> The flow of how we share files via bluetooth in gaia:
> 
> - Gallery or Music (File) -web activity-> Bluetooth app (File) ->
> mozBluetooth (File)
> 
> But currently result in:
> 
> - Gallery or Music (File) -web activity-> Bluetooth app (Blob) ->
> mozBluetooth (Blob)
> 
> Looks like after passing by web activities, a File object will become a Blob
> object,
> but mozBluetooth api needs File, not Blob object because it needs File.name
> and File.size
> Blobs doesn't contain .name and .size
> 

One correction, Blob does have .size, so the only missing property is .name for mozBluetooth api.

> So that's why it always shows failed for current gaia.

Updated

5 years ago
Component: Gaia → Gaia::System::Bluetooth
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811615
You need to log in before you can comment on or make changes to this bug.