Closed Bug 811294 Opened 13 years ago Closed 13 years ago

release runner should copy files from default -> production instead of transplanting

Categories

(Release Engineering :: Release Automation, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: bhearsum)

Details

(Whiteboard: [shipit])

We hit an issue today where release runner failed to start Thunderbird 17.0b3 because 'hg transplant' failed. That command failed because of differences between the release config on default vs. production. Now that we're writing out a complete new release config to default anyways, we should just copy it to production instead of doing a risky transplant. This would mean that any changes made to the non-templatized configs would definitely get overwritten, but that's a feature IMO.
Assignee: nobody → bhearsum
This turned out to be pretty easy. 90% sure I've got it done in https://github.com/bhearsum/tools/commit/b70886ad91c44beddf0f56a11319dee08dbbce30 Needs a bit more testing though.
Whiteboard: [kickoff]
This is fixed in the latest version of release runner.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [kickoff] → [shipit]
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.