Last Comment Bug 811467 - Increase image decode chunk size
: Increase image decode chunk size
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: x86 Windows 7
: -- normal with 1 vote (vote)
: mozilla19
Assigned To: Jeff Muizelaar [:jrmuizel]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 13:43 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-12-05 14:24 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Increase the default to 16384 (876 bytes, patch)
2012-11-13 14:11 PST, Jeff Muizelaar [:jrmuizel]
jmuizelaar: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-11-13 13:43:45 PST
The current size 4096, using telemetry we can see that we can do about image decoding at around 10000 KB/s. This means we can do about 10240 bytes per ms. Since we have 5ms to do the decoding that means we should be able to 51200 bytes in 5ms. I'd suggest we change to 16384 as that gives a healthy margin.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-11-13 14:11:29 PST
Created attachment 681209 [details] [diff] [review]
Increase the default to 16384

Increase this limit to 16384. Note tenfour reverted the changes in 666352 for performance reasons.
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-11-13 15:14:04 PST
Comment on attachment 681209 [details] [diff] [review]
Increase the default to 16384

(this is joe honest)
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-11-13 15:43:12 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/cc210f0643e1
Comment 4 Ed Morley [:emorley] 2012-11-14 07:01:05 PST
https://hg.mozilla.org/mozilla-central/rev/cc210f0643e1
Comment 5 Nicholas Nethercote [:njn] 2012-11-16 13:47:03 PST
Does this have any impact on memory consumption?  I have no idea how many of these chunks we have live at once.
Comment 6 Joe Drew (not getting mail) 2012-11-16 14:05:06 PST
Only temporarily in the decoder. These chunks are written from data buffers we are already holding on to.
Comment 7 Jeff Muizelaar [:jrmuizel] 2012-11-16 14:12:31 PST
(In reply to Joe Drew (:JOEDREW! \o/) from comment #6)
> Only temporarily in the decoder. These chunks are written from data buffers
> we are already holding on to.

And likely not really even in the decoder, because it doesn't make a copy of the source data.

Note You need to log in before you can comment on or make changes to this bug.