Home screen application has died and will not restart/come back

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

P1
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ckolos, Assigned: gwagner)

Tracking

({b2g-testdriver, unagi})

unspecified
B2G C2 (20nov-10dec)
x86_64
Linux
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

64.00 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Earlier today, I removed some marketplace apps (stocks, daily express, etc) and changed my background. Mid-way through the process of deleting apps, the phone locked up and would no longer respond. I rebooted the phone but now when I reboot the phone I do see the unlock screen, however when I unlock the phone, I get a background, but no applications.

- Hitting the "Home" button drops me to the "The app is having problems" page.
- phone calls in work as expected, I am unable to access the phone functions to make outbound calls
- From the lock screen, the camera *does* work.
- removing the Tmobile SIM card and rebooting has no effect

Unfortunately, I can't see what build/rev I'm running. I have device 12984.
That sounds really really bad. Blocking.

Do you have a computer where you can run adb? If yes can you try to |adb logcat| when you boot the phone and pastebin the log somewhere? Thanks!
blocking-basecamp: ? → +
(Reporter)

Comment 2

6 years ago
once the OS loads, it's this stanza in a loop

http://ckolos.pastebin.mozilla.org/1941421
(Reporter)

Comment 3

6 years ago
sorry, new link with longer expiration:

http://ckolos.pastebin.mozilla.org/1941422
(Reporter)

Comment 5

6 years ago
I'm guessing not. ;)

Are there directions on how to reflash the phone anywhere? I didn't see anything in the dogfooding wiki.
(Assignee)

Comment 6

6 years ago
Oh sorry didn't see this comment. I will take a look.
(Assignee)

Comment 7

6 years ago
That's a strange bug. It seems that the permission DB got destroyed. 
I assume you tried to reboot after removing the battery for a little bit?
It would be great if I could get the permission DB off your device. Are you maybe in the SF or MV office?
(Reporter)

Comment 8

6 years ago
I should be able to pull the permissions DB from adb, no? If not, then yeah, there's not really an easy way for me to get the phone to you, short of shipping. I'm in the Chicago area.
(Assignee)

Comment 9

6 years ago
Yes you should be able to get it with:
adb pull data/local/permissions.sqlite

if you also want to take a look you can try:
sqlite3 permissions.sqlite
sqlite> select * from moz_hosts;
(Reporter)

Comment 10

6 years ago
Done. Results are here:

http://ckolos.pastebin.mozilla.org/1948527
(Assignee)

Comment 11

6 years ago
Ha no homescreen there. Seems like we remove the homescreen permissions when we delete apps :(
(Assignee)

Comment 12

6 years ago
We should tell people that they shouldn't try to uninstall apps. It will kill their phone right now.
Whiteboard: [dogfood-blocker]
(In reply to Chris Kolosiwsky [:ckolos] from comment #5)
> I'm guessing not. ;)
> 
> Are there directions on how to reflash the phone anywhere? I didn't see
> anything in the dogfooding wiki.

You're not in MV/SF/TO - are you on the stable updates or the developer nightlies?
I cannot reproduce this on the 11-14 stable update (git commit 1c884f4129266056) but am bumping the severity and hoping someone can look into a regression range and STR so that we do not accidentally ship this in the next stable update.
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → B2G C2 (20nov-10dec)
(Reporter)

Comment 15

6 years ago
Gregor: That's a feature! :)

Lukas: I honestly couldn't tell you. I believe I'm on stable updates as I just got the phone late Oct and had a delay in getting it connected to t-mobile. I had downloaded 2 updates since that time, both of them offered through the FFOS interface itself.
(Reporter)

Comment 16

6 years ago
Is there a file on the phone I can inspect to see the versioning?
(Reporter)

Comment 17

6 years ago
ah, nevermind, found build.prop:

ro.build.id=OPENMASTER
ro.build.display.id=OPENMASTER.28
ro.build.version.incremental=28
ro.build.version.sdk=15
ro.build.version.codename=AOSP
ro.build.version.release=4.0.4.0.4.0.4
ro.build.date=Wed Oct 17 08:21:50 PDT 2012
ro.build.date.utc=1350487310
ro.build.type=user
ro.build.user=jenkins
ro.build.host=builder1.ateam.phx1.mozilla.com
ro.build.tags=test-keys
(Assignee)

Comment 18

6 years ago
That doesn't look right. Can you get the gecko build id from the prefs.js file?
It should look like: user_pref("gecko.buildID", "20121119115940");
prefs.js in your profile directory.
adb pull /data/b2g/mozilla/9718qcrs.default/prefs.js

note that 9718qcrs.default will be different on your phone.
use "adb shell" to find the correct folder.
(Assignee)

Updated

6 years ago
Assignee: nobody → anygregor
(Reporter)

Comment 19

6 years ago
# Mozilla User Preferences

/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 */

user_pref("app.update.lastUpdateTime.background-update-timer", 1353355721);
user_pref("app.update.postupdate", true);
user_pref("browser.cache.disk.smart_size.use_old_max", false);
user_pref("dom.mozApps.used", true);
user_pref("gecko.buildID", "20121107130242");
user_pref("gecko.mstone", "18.0a2");
user_pref("idle.lastDailyNotification", 1353355909);
user_pref("network.cookie.prefsMigrated", true);
user_pref("places.database.lastMaintenance", 1352923908);
user_pref("places.history.expiration.transient_current_max_pages", 10662);
user_pref("privacy.donottrackheader.enabled", true);
user_pref("ril.data.mmsc", "");
user_pref("ril.data.mmsport", 0);
user_pref("ril.data.mmsproxy", "");
user_pref("storage.vacuum.last.index", 1);
user_pref("storage.vacuum.last.places.sqlite", 1352224149);
(Assignee)

Comment 20

6 years ago
(In reply to Chris Kolosiwsky [:ckolos] from comment #19)
> user_pref("gecko.buildID", "20121107130242");

That doesn't look like a "promoted to stable" build. Did you build or flash it yourself?
tchung: can you help to reproduce this bug?
(Reporter)

Comment 21

6 years ago
I haven't flashed anything and in fact, don't know where to download the images in the first place. ;)

As I said above, I was prompted to update the phone 2 times through the 'in-phone' notification/download method. I *thought* the second update had gone through, but I could be wrong.
(Assignee)

Comment 22

6 years ago
This doesn't show up in newer versions any more.

I assume your phone is still not usable? We could try to put a new permissionDB on your phone or you could just download and flash a new stable version.
Whiteboard: [dogfood-blocker]
(Reporter)

Comment 23

6 years ago
Gregor: That is correct. I've not had a usable phone since I opened this ticket. I'm fine with either alternative, but it seems like loading the most recent version skips the online update.
(Assignee)

Comment 24

6 years ago
Created attachment 684180 [details]
permission DB

Try to push this permission.sqlite file to your device like:
adb push permissions.sqlite data/local/permissions.sqlite

This should fix the problem
(Reporter)

Comment 25

6 years ago
done. I now have *no* homescreen at all. Not even the lock screen.

adb logcat output here:

http://ckolos.pastebin.mozilla.org/1950618
(Assignee)

Comment 26

6 years ago
Created attachment 684209 [details]
permission DB

argh you need an older permission database. Lets hope this one works now.
Attachment #684180 - Attachment is obsolete: true
(Reporter)

Comment 27

6 years ago
Sorry, it doesn't. :)
(Assignee)

Comment 28

6 years ago
Yeah lets just flash a new version on it. 
lsblakk: do we have any docs on re-flashing a dogfood phone?
(In reply to Gregor Wagner [:gwagner] from comment #28)
> Yeah lets just flash a new version on it. 
> lsblakk: do we have any docs on re-flashing a dogfood phone?

Mentioned in IRC but will close the loop here too.  We do not have flashing docs yet for remote testers since the B2G Test Driver program isn't being run outside of the three largest offices yet. This will be changing in the next week or so and there will be docs (and access to builds) available.
It doesn't look like this can be reproduced with the latest stable builds.  Please re-nom if it can.
blocking-basecamp: + → -
(Reporter)

Comment 31

6 years ago
I am still waiting for some sort of instruction on flashing this phone. It is currently a lovely paperweight.
You can contact Lukas Blakk for help.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.