Closed Bug 811602 Opened 10 years ago Closed 8 years ago

[KEYBOARD] "Move cursor to the next field on a form" not working - MozTrap

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-basecamp:-)

RESOLVED DUPLICATE of bug 1035641
blocking-basecamp -

People

(Reporter: wachen, Unassigned)

References

Details

(Whiteboard: v2, UX-P2)

*Environment:
Phone - Unagi
Gaia Master(git) - 139b4ff3d4e7cae1eb19922ca5e258b48cebd99e
Gecko Nightly(git) - 43cff61762580cc1d870703ce40be8f3b011d80f
&
gaia master(git): 1549eb82367e0da38198cb3d458def15d829527a
gecko aurora(hg): 114166:c07b17e59971

*How to reproduce:
[Keyboard & Text-Handling] - Move cursor to the next field on a form
https://moztrap.mozilla.org/manage/case/3976/

*Expected Result:
  As the test cases suggest, it should go to next field by using enter/next button

*Actual Result:
  Enter doesn't work for going to next field. Also, there is no next button sighted.

*Sidenote:
  1. This is MozTrap [Keyboard & Text-Handling] test case 15. It looks like that this feature is not implemented
  2. This is targeted for B2G M4
blocking-basecamp: --- → ?
Component: General → Gaia
What about using "Enter" key ?
blocking-basecamp: ? → +
Priority: -- → P2
I just found that we agreed to remove this from v1 -- this is user story KBandText-015 and has been marked OOS. Recommend blocking- and remove this test case.
blocking-basecamp: + → ?
(In reply to Dylan Oliver [:doliver] from comment #2)
> I just found that we agreed to remove this from v1 -- this is user story
> KBandText-015 and has been marked OOS. Recommend blocking- and remove this
> test case.

Thanks! This will involve some painful changes otherwise.
Hi, 

Please do remove the test cases that is not for B2G M4 so that we don't need to open too many unnecessary bug tickets.

As for enter key, that's filed in another issue and it doesn't work too.

If possible, please provide us with detailed spec.

Thanks.
blocking-basecamp: ? → -
OOS for V1
Component: Gaia → Gaia::System::Keyboard
Priority: P2 → --
Whiteboard: v2
FWIW, I don't think we should be delaying this for V2. Refocusing from one textfield to another usually hides and shows the keyboard, which is utterly annoying and slow. Offering this convenience would alleviate the issue. Otherwise we should at least make sure the kbd doesn't dance up and down.

I'm going to flag this UX-P2 for reconsideration.
Whiteboard: v2 → v2, UX-P2
Omega, do we still want to implement this feature? If so let's make this bug blocks bug 983043?
Flags: needinfo?(ofeng)
Yes, we still want to do that, but more like bug 1035641, or you think they are basically the same?
Flags: needinfo?(ofeng) → needinfo?(timdream)
They provide the same purpose for the user I think. It sounds like you think they are the same -- I am duping the two bugs.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(timdream)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.