If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[KEYBOARD] "URL Keyboard activation" not working - MozTrap

RESOLVED INVALID

Status

Firefox OS
Gaia::Browser
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: ypwalter, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: testrun 2)

(Reporter)

Description

5 years ago
*Environment:
Phone - Unagi
Gaia master(git): 1549eb82367e0da38198cb3d458def15d829527a
Gecko aurora(hg): 114166:c07b17e59971

*How to reproduce:
[Keyboard & Text-Handling] - URL Keyboard activation
https://moztrap.mozilla.org/manage/case/3920/

*Expected Result:

*Actual Result:
  In step3, the test failed due to that long tapping of bookmarked URL didn't come out. Also, I think URL mode didn't finish yet in virtual keyboard

*Sidenote:
  1. This is MozTrap [Keyboard & Text-Handling] test case 31. It looks like that this feature is not implemented
  2. This is targeted for B2G M4
  3. Suggested item: please make sure auto completion in URL doesn't come with a space. It would be annoying if auto completed item always come with a space after the word in URL.
I think this test case is invalid.

The awesomebar isn't a URL input, it's used both for entering URLs and searches, so uses a text input and the standard text keyboard at the moment.

Long tapping bookmarks to edit them is out of scope for v1.
(Reporter)

Comment 2

5 years ago
Ben, do you know who to contact to revise the test cases and who to contact to get most up-to-date spec/user stories?
blocking-basecamp: --- → ?
Status: NEW → RESOLVED
blocking-basecamp: ? → -
Last Resolved: 5 years ago
Resolution: --- → INVALID
To answer Walter's question...

Long tapping a bookmark to edit/remove it is user stories BROWSER-045 and BROWSER-047 which are marked as "out of scope" for v1 on the Firefox OS v1 Application Status spreadsheet https://docs.google.com/spreadsheet/ccc?key=0Ajt_meMlK3MOdHphdnV2a2RvcU9MZmd3cDlIQnZBMVE#gid=1

The URL bar was changed to input type=text, as described in this bug https://bugzilla.mozilla.org/show_bug.cgi?id=797867 though there is still an open discussion on this topic.

Comment 4

5 years ago
Unagi build 20130104070203

The fourth step on test case #3923 fails due to no edit option

Comment 5

5 years ago
UCID: kbandtext-059
https://moztrap.mozilla.org/results/case/62684/
Whiteboard: testrun 2
You need to log in before you can comment on or make changes to this bug.