SPDY POST upload (after 5-10 mins inactivity) prematurely hangs after 65536 bytes




Networking: HTTP
5 years ago
5 years ago


(Reporter: Alex Markham, Unassigned)


17 Branch
Windows 7

Firefox Tracking Flags

(Not tracked)



(2 attachments)



5 years ago
Created attachment 681472 [details]
firefoxhttplog-hang.log - HTTP log from firefox showing the upload hang.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121106195758

Steps to reproduce:

Enter the url of my spdy enabled website into the address bar.
Log in
Open an upload form for a file.
Wait 5-10 mins (everything works fine if you don't wait)
Submit the POST upload with a file over 65535 bytes (eg 4mb)

Actual results:

Firefox V 17b05 - The upload hangs for 45 seconds after 65535 bytes have been transmitted. It resumes at full speed after that.

Firefox V 16.0.1 - upload hangs after 65535 b transmitted for around 45 seconds and then aborts the upload. (possibly continues on v17 due to fix in https://bugzilla.mozilla.org/show_bug.cgi?id=790184 [SPDY] Firefox V15 & 15.0.1 fails with attachment upload on gmail with squid proxy? )

Expected results:

With SPDY disabled (in about:config network.http.spdy.enabled: false) There are no issues.
Chrome has no hang either.

Server is apache mod_spdy, as an ssl reverse proxy to haproxy, which then passes onto nodejs.

Wireshark log shows that firefox stopped sending data, and then resumes after the pause.

This bug only happens if there is an inactivity of 5-10 mins on the SPDY connection. Fine otherwise.

HTTP log of firefox shows this:
SpdyStream3 this=daf64c0, id 0x1 request body suspended because remote window is 0.
SpdySession3 8c706e0 will stream daf64c0 0x1 suspended for flow control
SpdySession3 8c706e0 could not identify a stream to write; suspending.

Then after a wait, it resumes

Comment 1

5 years ago
Created attachment 681482 [details]
Server side log of the upload hang

Also attaching server side log.
I should also add that this also happens on Ubuntu Firefox 16.0.1 at the same point.
I also tried the server (the point of contact - httpd mod_spdy ssl decryptor machine) with net.ipv4.tcp_window_scaling = 0 and I get the same result.
Could you please try a trunk build (nightly, Firefox19) because there are a few SPDY bugs fixed.

In case that you can still reproduce the issue, can you please attach a http log generated by the trunk build ?
-> https://developer.mozilla.org/en-US/docs/HTTP_Logging
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
probably a dup of https://bugzilla.mozilla.org/show_bug.cgi?id=809913

which has been on nightly for a few days - get a new nightly build to verify it.

Comment 4

5 years ago
It works correctly on the nightly build of Firefox 19
It does look like a dupe of 809913, same symptoms and I saw the same logging as that.
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809913
You need to log in before you can comment on or make changes to this bug.