Search results get weird in Chrome when going back in history

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cvan, Unassigned)

Tracking

Points:
---

Details

(Whiteboard: [u=dev c=mkt-search p=], URL)

(Reporter)

Description

6 years ago
User-Agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_6) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

Steps to reproduce:
1) Go to https://marketplace-dev.allizom.org/search/
2) Click the "More" button at the button.
3) Click one of the apps in the search results. You're taken to its app detail page.
4) Go back. You're taken back to the search results page, and it looks like this: http://i.imgur.com/NGXVx.png

I'm blaming Chrome for not respecting the Vary header, but there could be more at play here.

NOTE: Reproducible in production.

Comment 1

6 years ago
Is this reproducible if dbuc is not within 100 meters of your computer?

Comment 2

6 years ago
Appears to be fixed by my hunch:

https://github.com/mozilla/zamboni/commit/07d3f3e571dd7204358789a0630e6473f6cf268c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 3

6 years ago
Issue is still reproducing in https://marketplace-dev.allizom.org/search/ on Chrome 23.0 (Win 7)
Please see screencast http://screencast.com/t/4sFImxR52SSj
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

6 years ago
I cannot reproduce this with Chrome 24 on Mac OS X on today's production site. Will have to check on Windows.
Whiteboard: [u=dev c=mkt-search p=]

Comment 5

6 years ago
I wasn't able to reproduce this on Windows 7 / Chrome 24 either.

Who gets to do a final QA call on this? Should I assign this to krupa or add some flag?

Comment 6

6 years ago
I cannot reproduce this issue on Chrome anymore since we got rid of the back button for desktop. I am closing this bug as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.