[traceback] FieldError: Cannot resolve keyword 'price' into field in search suggestions

VERIFIED FIXED in 2013-06-27

Status

Marketplace
Search
P3
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: cvan, Assigned: robhudson)

Tracking

2013-06-27
Points:
---

Details

(Whiteboard: [u=dev c=mkt-search p=], URL)

(Reporter)

Description

6 years ago
http://sentry.dmz.phx1.mozilla.com/marketplace/group/3130/

FieldError: Cannot resolve keyword 'price' into field. Choices are: _backup_version, _current_version, _reviews, _upsell_from, _upsell_to, abuse_reports, addon_recommendations, addon_tags, addonblueviaconfig, addoncategory, addoncollectioncount, addondevicetype, addonexcludedregion, addonlog, addonpremium, addonpurchase, addons, addons_dependencies, addonsharecount, addonsharecounttotal, addonuser, admin_review, admin_review_type, annoying, app_domain, app_slug, approval, appsubmissionchecklist, appsupport, authors, auto_repackage, average_daily_downloads, average_daily_users, average_rating, bayesian_rating, categories, category, charity, collectionaddon, collections, compatoverride, content_ratings, contribution, created, default_locale, dependencies, dependent_on, description, dev_agreement, developer_comments, disabled_by_user, downloadcount, editorsubscription, enable_thankyou, escalationqueue, eula, external_softwa re, feature, frozenaddon, get_satisfaction_company, get_satisfaction_product, guid, highest_status, homepage, hotness, icon_type, id, image_assets, inappconfig, installed, is_packaged, last_updated, legacyaddonlog, locale_disambiguation, make_public, manifest_url, modified, monthlypick, mozilla_contact, name, nomination_message, outstanding, payment_data, paypal_id, paypalcheckstatus, performance, persona, premium_type, prerelease, previews, privacy_policy, public_stats, recommended_for, rereviewqueue, rsskey, share_count, site_specific, slug, status, submitstep, suggested_amount, summary, support_email, support_url, synced_collections, syncedcollectionaddon, tags, target_locale, thankyou_note, the_future, the_reason, total_contributions, total_downloads, total_reviews, trusted, ts_slowness, type, updatecount, versions, view_source, wants_contributions, weekly_downloads

Logger:	root	Level:	error
Server:	web26.addons.phx1.mozilla.com	First Seen:	Nov. 14, 2012
Stacktrace
Stacktrace (most recent call last):  File "django/core/handlers/base.py", line 111, in get_response response = callback(request, *callback_args, **callback_kwargs) File "amo/decorators.py", line 131, in wrapper response = func(*args, **kw) File "search/views.py", line 481, in ajax_search_suggestions results += suggestions(request).items File "search/views.py", line 364, in items return self.build_list() File "search/views.py", line 348, in build_list for item in self.queryset()[:self.limit]: File "search/views.py", line 398, in queryset res = res.filter(premium_type__in=amo.ADDON_FREES, price=0) File "django/db/models/query.py", line 624, in filter return self._filter_or_exclude(False, *args, **kwargs) File "django/db/models/query.py", line 642, in _filter_or_exclude clone.query.add_q(Q(*args, **kwargs)) File "django/db/models/sql/query.py", line 1250, in add_q can_reuse=used_aliases, force_having=force_having) File "django/db/models/sql/query.py", line 1122, in add_filter process_extras=process_extras) File "django/db/models/sql/query.py", line 1316, in setup_joins "Choices are: %s" % (name, ", ".join(names)))
Http
URL:	https://marketplace.mozilla.org/search/suggestions
Method:	GET
Query:	'q=500&cat=apps'
Haven't seen this since yesterday.  Can we reproduce?
Target Milestone: 2012-11-15 → 2012-11-22
(Reporter)

Comment 2

6 years ago
(In reply to Wil Clouser [:clouserw] from comment #1)
> Haven't seen this since yesterday.  Can we reproduce?

Yep:

https://marketplace.firefox.com/search/suggestions?q=500&cat=apps
https://marketplace.firefox.com/search/suggestions?q=500

Comment 3

5 years ago
I cannot reproduce this with the provided urls, but sentry shows the last entry on Jan 26 and I couldn't spot any relevant code changes after that date.

So this is likely still the case, but not that easy to reproduce anymore.
Whiteboard: [u=dev c=mkt-search p=]

Updated

5 years ago
Target Milestone: 2012-11-22 → ---
(Assignee)

Comment 4

5 years ago
Unable to reproduce. Last seen Jan 26th.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Duplicate of this bug: 851420

Comment 6

5 years ago
This happened again, see https://bugzilla.mozilla.org/show_bug.cgi?id=851420
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 7

5 years ago
This is now a 404 as we're not doing search suggestions in fireplace.
Assignee: nobody → robhudson.mozbugs
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-06-27

Comment 8

5 years ago
https://marketplace.firefox.com/search/suggestions now 404s
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.