Encoding checks needed on getPageSource

RESOLVED FIXED in mozilla31

Status

Testing
Marionette
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: automatedtester)

Tracking

Trunk
mozilla31
ARM
Gonk (Firefox OS)
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

5 years ago
TEST-UNEXPECTED-FAIL : UnicodeEncodeError: 'ascii' codec can't encode character u'\xab' in position 2982: ordinal not in range(128)

Trying to print out: https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/index.html

This is in the 'Cellular & Data' settings in Gaia.
(Assignee)

Comment 1

5 years ago
Created attachment 687297 [details] [diff] [review]
test with unicode char in the source.

I can't reproduce this but have added a test

Comment 2

5 years ago
Try run for f1e0302c3d4d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f1e0302c3d4d
Results (out of 2 total builds):
    success: 1
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-f1e0302c3d4d

Comment 3

5 years ago
Try run for 4ac352c50e31 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4ac352c50e31
Results (out of 4 total builds):
    exception: 1
    success: 3
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-4ac352c50e31

Comment 4

5 years ago
Try run for 4ac352c50e31 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4ac352c50e31
Results (out of 5 total builds):
    exception: 1
    success: 3
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-4ac352c50e31

Comment 5

5 years ago
Try run for 8992025c45b5 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=8992025c45b5
Results (out of 4 total builds):
    success: 3
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-8992025c45b5

Comment 6

5 years ago
Try run for 31f328e56ebf is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=31f328e56ebf
Results (out of 9 total builds):
    success: 8
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-31f328e56ebf

Comment 7

5 years ago
Try run for 31f328e56ebf is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=31f328e56ebf
Results (out of 10 total builds):
    success: 8
    warnings: 2
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-31f328e56ebf
(Assignee)

Comment 8

5 years ago
Created attachment 698621 [details] [diff] [review]
test with unicode char in the source.

I have turned off page_source tests on b2g because of XUL failures. Is there a way that I can only turn off the XUL tests only or should I split the tests?
Attachment #687297 - Attachment is obsolete: true
Attachment #698621 - Flags: review?(jgriffin)
You can use the @skip_if_b2g decorator on test methods you want to skip on B2G.
Comment on attachment 698621 [details] [diff] [review]
test with unicode char in the source.

Review of attachment 698621 [details] [diff] [review]:
-----------------------------------------------------------------

Can we please get a simpler test page?  I don't like checking in huge HTML files of which 99% is irrelevant to the test, and which contain lots of <link> elements to content that isn't present.

Otherwise, looks fine, and thanks for adding this!
Attachment #698621 - Flags: review?(jgriffin) → review-
(Assignee)

Comment 11

5 years ago
Redone try for mobile

https://tbpl.mozilla.org/?tree=Try&rev=1bb6395e57c6

To make sure that it doesnt go orange on the chrome test
(Assignee)

Comment 12

5 years ago
Created attachment 699774 [details] [diff] [review]
v2 - adding test with unicode in test page to check we can still pull it back
Attachment #698621 - Attachment is obsolete: true

Comment 13

5 years ago
Try run for 54354597e25e is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=54354597e25e
Results (out of 2 total builds):
    success: 1
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dburns@mozilla.com-54354597e25e
(Assignee)

Comment 14

4 years ago
Created attachment 8411779 [details] [diff] [review]
Adding a test for checking that page_source handles unicode chars
Attachment #8411779 - Flags: review?(jgriffin)
(Assignee)

Updated

4 years ago
Attachment #699774 - Attachment is obsolete: true
(Assignee)

Comment 15

4 years ago
 https://tbpl.mozilla.org/?tree=Try&rev=37dfe7a2e54d
 https://tbpl.mozilla.org/?tree=Try&rev=d1451a84233f
Comment on attachment 8411779 [details] [diff] [review]
Adding a test for checking that page_source handles unicode chars

Review of attachment 8411779 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure we need both 'b2g = false' and @skip_if_b2g, but otherwise looks good!
Attachment #8411779 - Flags: review?(jgriffin) → review+
(Assignee)

Comment 17

4 years ago
Created attachment 8412599 [details] [diff] [review]
Adding a test for checking that page_source handles unicode chars
(Assignee)

Updated

4 years ago
Attachment #8412599 - Flags: review+
(Assignee)

Updated

4 years ago
Attachment #8411779 - Attachment is obsolete: true
(Assignee)

Comment 18

4 years ago
landed in https://hg.mozilla.org/integration/mozilla-inbound/rev/ff9d5d0bde0a
https://hg.mozilla.org/mozilla-central/rev/ff9d5d0bde0a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.