Unable to install packaged apps on FF OS

RESOLVED DUPLICATE of bug 809772

Status

Marketplace
Consumer Pages
P1
normal
RESOLVED DUPLICATE of bug 809772
6 years ago
6 years ago

People

(Reporter: Victor Carciu, Unassigned)

Tracking

({regression})

2012-11-15
ARM
Gonk (Firefox OS)
regression
Points:
---

Details

(Whiteboard: [janus], URL)

(Reporter)

Description

6 years ago
Prerequisites:
FF OS device or emulator needed.

Steps to reproduce:
1.On FF browser from your FF OS , open http://people.mozilla.com/~fdesre/openwebapps/test.html
2.Press "Install Packaged app" button

Expected results:
The packaged app is installed

Actual result:
Nothing happens after pressing the button.
This is also reproducible for http://people.mozilla.com/~fdesre/openwebapps/test.html (http://bit.ly/KKHgPu). Has anything changed on the API side of things - Fabrice, Jason?
OS: Windows 7 → Gonk (Firefox OS)
Priority: -- → P1
Hardware: x86_64 → ARM
(Reporter)

Comment 2

6 years ago
I just observed that the apps were installed , but they are visible only after restarting the emulator.

I think that we can keep the bug for tracking this issue.
(Reporter)

Comment 3

6 years ago
Please note that the issue from comment #2 is reproducible when installing packaged apps directly from MP app installed on FF OS.

When tried to install from browser using http://people.mozilla.com/~fdesre/openwebapps/test.html nothing happened(no app installed even after restarting the emulator).
When signing and signature verification lands, I would expect this not to work assuming this test app isn't signed.

Aside: Is there a way to test apps without signing -- a pref setting or anything?
(In reply to Victor Carciu from comment #3)

> When tried to install from browser using
> http://people.mozilla.com/~fdesre/openwebapps/test.html nothing happened(no
> app installed even after restarting the emulator).

That's expected, I modified this one to test install error cases.... 

If you see the app after "rebooting", this means that the gecko side went ok, and that something failed in gaia during install.
So I'm confused what the problem here is. Fabrice's comment implies he modified the test page to test an error case, which implies that this isn't a bug. What's the bug here, if any?
(Reporter)

Comment 7

6 years ago
The bug is that after installing an app you can see it only after "rebooting" as Fabrice said in comment #5.
(In reply to Victor Carciu from comment #7)
> The bug is that after installing an app you can see it only after
> "rebooting" as Fabrice said in comment #5.

Ah okay. Smells like a dup then!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809772
You need to log in before you can comment on or make changes to this bug.