BaselineCompiler: Implement double truncating version of bitwise ops

RESOLVED DUPLICATE of bug 847205

Status

()

defect
RESOLVED DUPLICATE of bug 847205
7 years ago
6 years ago

People

(Reporter: evilpie, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
For good performance on some benchmarks we really need a version where we truncate doubles to ints.
Reporter

Updated

7 years ago
Blocks: BaselineInlineCaches
No longer blocks: BaselineCompiler
OS: Linux → All
Hardware: x86_64 → All
Reporter

Updated

7 years ago
No longer depends on: 811766
Reporter

Updated

7 years ago
Depends on: 814179
I did not realize this bug already existed when I created the (Double|Int32 BITOP Double|Int32) bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 847205
You need to log in before you can comment on or make changes to this bug.