Closed Bug 811894 Opened 7 years ago Closed 6 years ago

crash in nsLayoutUtils::ChangeMatrixBasis

Categories

(Core :: Layout, defect, critical)

Other Branch
x86_64
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aja+bugzilla, Unassigned)

References

Details

(Keywords: 64bit, crash, Whiteboard: [Australis:M6][startupcrash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-cf7e9834-f575-43fa-9b67-4e67a2121114 .
=============================================================
Startup crash updating UX-nightly 64bit on win8 (32bit was ok).
Probable cause, landing of:
Bug 738491 - Implement the Australis tab shape for Windows.
Component: Graphics → Layout
Whiteboard: [startupcrash]
Component: Layout → Graphics
Keywords: 64bit
Whiteboard: [startupcrash]
Component: Graphics → Layout
Whiteboard: [startupcrash]
This seems to be fixed now. See:
https://bugzilla.mozilla.org/show_bug.cgi?id=738491#c65
This started (again) on 2012-11-14, see more reports at https://crash-stats.mozilla.com/report/list?signature=nsLayoutUtils%3A%3AChangeMatrixBasis%28gfxPoint3D%20const%26%2C%20gfx3DMatrix%20const%26%29

Also, this is the topcrash on trunk over the recent 3 days, so nominating for tracking.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> Also, this is the topcrash on trunk over the recent 3 days, so nominating
> for tracking.
64-bit build crashes are not tracked. In addition, it's not a top crasher in Nightly but UX Nightly.
Hardware: All → x86_64
I believe we still support 64-bit Windows Nightlies so this may block an m-c landing if it's still reproducible.
I did a Win64 try push at https://tbpl.mozilla.org/?tree=Try&rev=067d588a4602 that someone can test with when it's ready.

Download builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mozilla@noorenberghe.ca-067d588a4602
Flags: needinfo?
Whiteboard: [startupcrash] → [Australis:M6][startupcrash]
Flags: needinfo? → needinfo?(mconley)
There's no crash here for me on Windows 8 or 7. I think we're done here, unless someone is still experiencing it.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mconley)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.