[e.me][everything.me][evme] After running the RottenTomatoes e.me app, e.me no longer appears

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Everything.me
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: vingtetun)

Tracking

({otoro, unagi})

unspecified
B2G C2 (20nov-10dec)
x86
Mac OS X
otoro, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

Created attachment 681731 [details]
screenshot

## Environment :
Unagi phone, build 20121114
  
## Repro :
1. swipe to everything.me screen
2. select movies -> Rottentomates
3. set remember my choice to off for geolocation for homescreen 
4. select allow
5. swipe to the landing page and swipe back

## Expected :
1. rotten tomatoes webapp

## Actual :
1. e.me completely disappears, long tapping on home shows nothing; no wrapper is shown

## Note :
It looks like it's geolocation related, and probably a dup of bug 803615?
Is there some sort of debug flag I can turn on to see what's going on better in logcat?
What I don't understand in those steps to reproduce is between 4 and 5. Does the application is not on the foreground anymore?

Also when you say e.me dissapears, do you mean the search page on the left side of the homescreen?
Assignee: nobody → ran
blocking-basecamp: ? → +
Priority: -- → P1

Updated

5 years ago
Component: Gaia::Homescreen → Gaia::Everything.me

Comment 4

5 years ago
Marking for C2, given this meets the criteria of known P1/P2 blocking-basecamp+ bugs at the end of C1.
Target Milestone: --- → B2G C2 (20nov-10dec)
Ok I can reproduce and this sounds really bad.
Created attachment 685629 [details] [diff] [review]
Patch

This code add a timeout of 2 seconds on the geolocation returns. Otherwise we wait forever. It also cancel the current action if the user returns to the homescreen in the 2 seconds interval.
Attachment #685629 - Flags: review?(ran)
Assignee: ran → 21
Attachment #685629 - Flags: review?(ran) → review?(crdlc)
Comment on attachment 685629 [details] [diff] [review]
Patch

> this.cancel = function() {

Please add name to the function because I requested to Ran to delete anonymous function in all code :) We need give example jjaja
what is the branch to test? the code is OK for me
(In reply to crdlc from comment #8)
> what is the branch to test? the code is OK for me

The branch is at: https://github.com/vingtetun/gaia/tree/811934
Attachment #685629 - Flags: review?(crdlc) → review+
https://github.com/mozilla-b2g/gaia/commit/c778f72ac3c4d788885562cee5a4b44345c32956
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
Unfortunately I cannot test this because rotten tomatoes app currently appears to crash on launch (if "remember my choice" is unselected".  

https://bugzilla.mozilla.org/show_bug.cgi?id=818201

Comment 12

5 years ago
Ahh, well, it doesn't crash actually - it just doesn't launch.   Is it possible to test this fix WITHOUT enabling "remember my choice"?

Comment 13

5 years ago
2012/28/01 build. Gecko-cfad7c9 Gaia-6c53dfd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.