IMAP base path discarded

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: ianus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121026174634

Steps to reproduce:

I am trying to get the contents of an IMAP account where a base path of /archive has been specified.
It's an Exchange 2010 server accessed through Davmail.
Other folders of the accounts are retrieved correctly from the base path /archive, even sub-folders of /archive/INBOX, but /archive/INBOX is not.
Whenever I click on the Inbox folder of the account that has a base path of /archive, I get a status message like „opening INBOX”, though if I click on a sub-folder of that same INBOX (of the account that has a base path of /archive) I get a status message like „opening /archive/INBOX/whatever”.
The exact version of TB is 16.0.2 (x86-64) on Slackware64 14.0.


Actual results:

Instead of getting the contents of /archive/INBOX I get the contents of /INBOX.


Expected results:

Should get the contents of /archive/INBOX not the contents of /INBOX.
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Can you please create and imap log (https://wiki.mozilla.org/MailNews:Logging)and add it as an attachment to this bug?
Flags: needinfo?(ianus)
Can you please create and imap log (https://wiki.mozilla.org/MailNews:Logging)and add it as an attachment to this bug?
(Reporter)

Comment 3

5 years ago
In fact I have tried to do just that, but after

export NSPR_LOG_MODULES=imap:5
export NSPR_LOG_FILE=/home/<username>/.<file_name>
thunderbird

I could see the file created, but nothing has been logged.
The file was empty (not missing and it didn't exist before turning on logging).
Of course during that TB session I have accessed several accounts and their folders, including the archive one.

echo $NSPR_LOG_MODULES 

did return „imap:5”
Anything else I could do or something I did wrong?

I did turn on logging in davmail and I could see the requests to the folders.
In those logs I could see that davmail has been accessing the „INBOX” folder (instead of the „/archive/INBOX” one) whenever I clicked the „Inbox” folder in the account that had a base path of „/archive”.
Flags: needinfo?(ianus)
Do you have write access to the directory specified?
Did you shut down the mailnews application? (the log file is buffered in memory)
Did you restart your mailnews application, and wipe out the log of the session you wanted to debug? (every restart wipes out the previous log)

If you still do not have luck with the imap log, you could post the davmail log if it shows the actual protocol messages.
(Reporter)

Comment 5

5 years ago
Of course I had right permissions (the log was in my hove folder, was absent before turning on logging and got created after that - I suppose if TB could created a file it would have the rights to write to it).
Of course I gave it a chance to write the buffers to disk: deleted the file, started TB, did the folder selections, checked the file, closed TB, checked the file again - prior to firing up TB again.

I could provide the logs for Davmail, but please let me know what part are you interested in (DavMail, HttpClient or Wire) as capturing all and than anonymizing it all would take days.
OK, try this. Run `NSPR_LOG_MODULES=imap:5 thunderbird`. The log data should be printed to standard output.
correction standard error. If you see log messages in your consoles using the above command, then

NSPR_LOG_MODULES=imap:5 thunderbird 2> imap.log

should get it redirected into a file.
(Reporter)

Comment 8

5 years ago
I have tried what you have said, but even though the file gets created, it is empty.
And there is absolutely nothing logged to the console ether.
Just like when I have used the method described above.

bash-4.2$ export NSPR_LOG_MODULES=imap:5
bash-4.2$ export NSPR_LOG_FILE=/home/<username>/imap.log
bash-4.2$ thunderbird
(Reporter)

Comment 9

5 years ago
I have also tried the installing TBTracer.
Whe I open the add-on's preferences dialog it confirms that the logging file is the one set in the environment variable and that the logging is what the environment variable says (imap) but the file is still empty and the add-on shows nothing in the log window. 
Interesting is that if I turn on HTTP logging in the add-on, and I access the calendar than I do get the logs for that access.

Comment 10

5 years ago
any further luck?
Flags: needinfo?(ianus)
(Reporter)

Comment 11

5 years ago
No.
I did not pursue the logging part anymore.
On the other hand, trying out the base path with another e-mail client I got the 
same results: everything has been requested with the base path except the INBOX which has been requested like that (with no base path).
I'm inclined to believe maybe this is the normal with IMAP.
I will just give up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ianus)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.