Closed Bug 812119 Opened 8 years ago Closed 8 years ago

[HOMESCREEN] Must reboot after deleting an app to see its icon disappear from homescreen

Categories

(Core Graveyard :: DOM: Apps, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

VERIFIED FIXED
B2G C2 (20nov-10dec)
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: dscravaglieri, Assigned: vingtetun)

References

Details

(Keywords: smoketest)

Attachments

(1 file)

gecko-aurora: 0d76df6f808d
gaia: 487a7c18c8ff08db7d2e76239e85e3e5eefcc8b7

Install an app from Marketplace
Open the app
Close the app
Delete the app

Expected:
Icon disappear from homescreen

Actual:
Icon still in home screen, must reboot.
blocking-basecamp: --- → ?
Keywords: smoketest
blocking-basecamp: ? → +
Priority: -- → P2
I did some debugging, and I found that app.manifestURL is undefined here, so we're never getting any icons to remove:
https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/grid.js#L853

Perhaps this is a problem with the event navigator.mozApps.mgmt.onuninstall is getting?
Assignee: nobody → philipp
Marking for C2, given this meets the criteria of known P1/P2 blocking-basecamp+ bugs at the end of C1.
Target Milestone: --- → B2G C2 (20nov-10dec)
Comment on attachment 684019 [details] [diff] [review]
Patch

Review of attachment 684019 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/apps/src/Webapps.js
@@ +753,2 @@
>            let event = new this._window.MozApplicationEvent("applicationuninstall",
> +                           { application : createApplicationObject(this._window, detail) });

You can just pass |msg| here and not care create the extra |detail| object I think.
Attachment #684019 - Flags: review?(fabrice) → review+
Component: Gaia::Homescreen → DOM: Apps
Product: Boot2Gecko → Core
Version: unspecified → Trunk
After addressing Fabrice's comment, is this patch ready to land?
Duplicate of this bug: 816094
I just decided to land this with Fabrice's comment addressed (I tested locally to make sure it worked):
https://hg.mozilla.org/integration/mozilla-inbound/rev/4f7114a9d050
Assignee: philipp → 21
Sorry, had to back this out for mochitest-other failures.
https://hg.mozilla.org/integration/mozilla-inbound/rev/822a1cfc322d

https://tbpl.mozilla.org/php/getParsedLog.php?id=17435308&tree=Mozilla-Inbound

3385 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug454235.xul | offscreen browser is not visible
9695 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/localstorage/test_app_uninstall.html | Test timed out.
9698 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/localstorage/test_clear_browser_data.html | no data - got bar, expected null
9700 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/localstorage/test_clear_browser_data.html | no data - got bar, expected null
9716 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/localstorage/test_clear_browser_data.html | Test timed out.
9730 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/webapps/test_bug_765063.xul | Test timed out.
9733 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/tests/mochitest/webapps/test_bug_795164.xul | Test timed out.
9734 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
9735 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 449 remaining tests.
9736 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | chrome://mochitests/content/chrome/dom/tests/mochitest/webapps/test_bug_795164.xul finished in a non-clean fashion, probably because it didn't call SimpleTest.finish()
This also had a Linux bc failure.

https://tbpl.mozilla.org/php/getParsedLog.php?id=17435568&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/dom/tests/browser/browser_webapps_permissions.js | Test timed out
Duplicate of this bug: 816292
Duplicate of this bug: 816587
Raising priority for smoketest blocker and to get this one back on the radar since it was backed out.
Priority: P2 → P1
(In reply to Dylan Oliver [:doliver] from comment #12)
> Raising priority for smoketest blocker and to get this one back on the radar
> since it was backed out.

I found the cause of failures. I sent a version on tre try to see how it performs.
https://hg.mozilla.org/mozilla-central/rev/66888378b4ac
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified through smoke tests + gaia ui test automation.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.