(unintentionally) double clicking on attachment runs two concurrent "save" task and corrupts the saved file.

RESOLVED DUPLICATE of bug 697125

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 697125
5 years ago
4 years ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When I try to save an attachment to a message in thunderbird,
either by mistake or mishandling of a pointing device,
I essentially double clicks on the attachment where, it seems, a single mouse click is enough.

Problem is that this two clicks caused by "double-click" seems to
run TWO (2) "save" threads concurrently (there does not seem to be a lock to serialize this), and as a result, while the saving of the first may start or even about to finish, the second thread may interfere, ESPECIALLY when a group of
attachments are to be saved, and I don't realize that the second dialog I am about to click is the FIRST window of the SECOND thread to save an already saved (or its saving is in operation) attachment.

If I click on this second dialog, then I mess up the saving process.
The typical symptom is that 
 - TB says something about it is not able to read the original source of the
   copy (I am using Japanese locale and not sure what the corresponding English message is), but the meaning of the message is very obscure: why on earth TB
   can not read the ATTACHMENT already in its folder(?!).

 - The two threads somehow does not cause the first obnoxious mysterious message 
   to appear, but they either
   - leaves corrupted attachment file, or
   - more likely it leaves ATTACHMENT-SAVED-FILENAME.part temporary file behind
     (note the ".part" suffix) and
     often I find 0-sized ATTACHMENT-SAVED-FILENAME.

It has shown up a few version before and not sure when exactly. But maybe within a last year(?)

Double-clicking is often done by mistake and this behavior of thunderbird saving feature is very obnoxious.

There ought to be a serialization mechanism so that another thread does not stomp on the already running saving operation of an attachment.

TIA
(Reporter)

Comment 1

5 years ago
> The typical symptom is that 
>  - TB says something about it is not able to read the original source of the
>    copy (I am using Japanese locale and not sure what the corresponding
> English message is), but the meaning of the message is very obscure: why on
> earth TB
>    can not read the ATTACHMENT already in its folder(?!).
> 

The exact message in Japanese look like the following (I was trying to save
MS-WORD .docx fiel, and thus ".docx.part" suffix is shown:
It can be translated as follows.
The message is very misleading IMHO. 


---
Translation:

The source file for the download is not readable and thus /tmp/SMCGxotz.docx.parat could not be saved.

Please retry later, or contact the site administrator.

----
Original

ダウンロード元ファイルが読み取れないため /tmp/SMCGxotz.docx.part を保存でき
ませんでした。

しばらく後で再度試すか、サーバ管理者に問い合わせてください。

Comment 2

5 years ago
Dupe of bug 697125?

Comment 3

5 years ago
Note that the target milestone for bug 697125 is TB 17
(Reporter)

Comment 4

5 years ago
Thanks for pointing to Bug 697125.

However, there it seems only opening a document is mentioned.
However, the saving is more seriously impacted because of the overwriting, and
failure to save attachment properly.

Although the patch seems to handle the case of saving in the same manner, 
just to be sure I will wait for TB 17 and report whether this problem is no longer seen or not.
(Reporter)

Comment 5

5 years ago
In the last couple of days my TB under linux got updated to v17.0

Voila, the problem has disappeared.

I can double-click on attachment, but only a single save thread runs.

Thank you. The bug is fixed!.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
-> WFM, FIXED is used for bugs with known patches that fixed the issue.
Resolution: FIXED → WORKSFORME

Comment 7

4 years ago
It's actually a dupe.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 697125
You need to log in before you can comment on or make changes to this bug.