CCs cause worse mid-flight collisions than ever before

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Production
x86_64
Linux

Details

(Reporter)

Description

6 years ago
I recall that CCs used to cause mid-flight collisions where you could still press the button that would cause no conflicting changes to be overwritten. That no longer appears to be the case; the CC-caused collisions that I encounter these days only show me one button which, as labelled, I would expect to replace all of the conflicting changes with just my CC. This is rather frustrating for an operation that feels like the easiest one to merge automatically.
since bug 69447 was fixed (september 6) cc changes shouldn't trigger mid-air collisions.
are you able to provide steps to reproduce?
(Reporter)

Comment 2

6 years ago
Earlier today, there was a new bug created (bug 812137). I opened it when only the initial description was present, and tried to CC myself by clicking "Save changes" and not explicitly changing the CC list. Meanwhile, the first comment was added, and the mid-air collision screen appeared.
If you read bug 69447 comment 16, this is by design currently. If the previous user had only added themselves to the cc list and not made a comment, then your change would not have caused a midair. Originally we were going to make comments/attachments not cause a midair but it was decided that this may have a bearing on whether you wanted to add yourself to the cc or not and would be better to show the comment first.

dkl
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

6 years ago
Isn't this worse than before, though? There's no option to continue with my change; either I overwrite all changes or need to refresh the original bug and CC myself again.
(In reply to Josh Matthews [:jdm] from comment #4)
> Isn't this worse than before, though? There's no option to continue with my
> change; either I overwrite all changes or need to refresh the original bug
> and CC myself again.

Should be the same as before with respect to comment collisions. We used to show a midair screen when a comment was made since you last loaded the bug. The only change recently is that if the other person *only* added themselves to the CC, your change(s) would not collide.

In your specific case, since the other person only made a comment, you could just take the "overwrite" option as previous comments are not removed.

dkl
(Reporter)

Comment 6

6 years ago
Huh. The text does not make that last bit clear at all.
yeah, the text on that page is confusing, and always has been.  Comments and changes to CC are never overwritten by a midair override, but it doesn't make that clear at all.  We should really make that remove that wording if all of the changes in the mid-air are ones that wouldn't be overwritten.
(But that's an upstream Bugzilla problem as much as a bmo one)
You need to log in before you can comment on or make changes to this bug.