Icon and screenshots previews are not displayed when an app is uploaded

VERIFIED FIXED in 2012-11-22

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: cboldan.mozbugs, Assigned: basta)

Tracking

({regression})

2012-11-22
x86_64
Windows 7
regression
Points:
---

Details

(Whiteboard: [janus])

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Load the Submit A New App page https://marketplace-dev.allizom.org/developers/submit/app
2. Submit a valid manifest and click Continue.
3. Add a custom icon and upload a screenshot/video for the app.

Expected results:
Icon and screenshots/videos previews are displayed.

Actual results:
Previews for the uploaded images/videos are not displayed. Issue is also reproducing in the Edit Listing page after the app is submitted.

Notes/Issues:
Verified on FF19 (Win 7).
Screencast for this issue http://screencast.com/t/kf9l4U0jys
Was this because celery was acting up?  It has been restarted since.

Comment 2

6 years ago
This is still happening.

Comment 4

6 years ago
Nov 15 10:53:24 celery1.dev.addons.phx1.mozilla.com: [][] z.task:INFO [Webapp:402351] Webapp does not exist :/data/www/addons-dev.allizom.org/zamboni/mkt/webapps/tasks.py:39
Nov 15 10:53:24 celery1.dev.addons.phx1.mozilla.com: [][] celery:INFO Task mkt.webapps.tasks.update_cached_manifests[12c078d6-b9fb-4e5f-8fe2-9912849c7976] succeeded in 0.0108079910278s: None :/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/celery/worker/job.py:332
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] z.task:INFO [1@None] Updating last updated for 402351. :/data/www/addons-dev.allizom.org/zamboni/apps/addons/tasks.py:37
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] celery:INFO Got task from broker: mkt.developers.tasks.fetch_icon[fb4b9662-beb4-4b79-b342-034db2cb83c9] :/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/celery/worker/consumer.py:374
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] z.mkt.developers.task:INFO [1@None] Fetching icon for webapp MozillaBall. :/data/www/addons-dev.allizom.org/zamboni/mkt/developers/tasks.py:388
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] z.celery:ERROR  Celery TASK exception: DoesNotExist: Addon matching query does not exist. :/data/www/addons-dev.allizom.org/venv/src/nuggets/celeryutils.py:46#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/venv/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 160, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 152, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/tasks.py", line 32, in version_changed#012    update_last_updated(addon_id)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/tasks.py", line 39, in update_last_updated#012    addon = Addon.objects.get(pk=addon_id)#012  File "/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/django/db/models/manager.py", line 131, in get#012    return self.get_query_set().get(*args, **kwargs)#012  File "/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/django/db/models/query.py", line 366, in get#012    % self.model._meta.object_name)#012DoesNotExist: Addon matching query does not exist.
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] z.celery:ERROR Celery TASK exception: DoesNotExist: Addon matching query does not exist. :/data/www/addons-dev.allizom.org/venv/src/nuggets/celeryutils.py:46#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/venv/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 160, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 152, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/tasks.py", line 32, in version_changed#012    update_last_updated(addon_id)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/tasks.py", line 39, in update_last_updated#012    addon = Addon.objects.get(pk=addon_id)#012  File "/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/django/db/models/manager.py", line 131, in get#012    return self.get_query_set().get(*args, **kwargs)#012  File "/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/django/db/models/query.py", line 366, in get#012    % self.model._meta.object_name)#012DoesNotExist: Addon matching query does not exist.
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] celery:INFO Task mkt.developers.tasks.fetch_icon[fb4b9662-beb4-4b79-b342-034db2cb83c9] succeeded in 0.0204710960388s: None :/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/celery/worker/job.py:332
Nov 15 10:53:24 celery2.dev.addons.phx1.mozilla.com: [][] celery:ERROR Task addons.tasks.version_changed[6b370a95-3556-4006-8699-bc964ca2e69b] raised exception: <MaybeEncodingError: Error sending result: '<ExceptionInfo: ObjectDoesNotExist('Addon matching query does not exist.',)>'. Reason: 'Can't pickle <class 'addons.models.DoesNotExist'>: attribute lookup addons.models.DoesNotExist failed'.> :/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/celery/worker/job.py:393#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/venv/lib/python2.6/site-packages/celery/concurrency/processes/pool.py", line 215, in worker#012    put((READY, (job, i, result)))#012  File "/usr/lib64/python2.6/multiprocessing/queues.py", line 366, in put#012    return send(obj)#012MaybeEncodingError: Error sending result: '<ExceptionInfo: ObjectDoesNotExist('Addon matching query does not exist.',)>'. Reason: 'Can't pickle <class 'addons.models.DoesNotExist'>: attribute lookup addons.models.DoesNotExist failed'.
Basta - this looks like a JS issue.  When uploading a URL is requested with /false on the end, so I think it's something simple.
Assignee: nobody → mattbasta
Target Milestone: --- → 2012-11-22
(Assignee)

Comment 6

6 years ago
It's not a JS error. When the page loads, the <img> tag has a URL which points at a URL which is 404ing. The `false` comes from a buggy retry script, but that only happens in Firefox. In Chrome, it stops polling and just leaves the image alone.
The URL 404s because the image isn't ready yet (it's being processed by celery).  The retry script is supposed to keep hitting it until it's not a 404.  So...that sounds like JS?
(Assignee)

Comment 8

6 years ago
Either way, the URL never stops being a 404. So that sounds like celery.
(Assignee)

Comment 9

6 years ago
...though the polling not continuing in Chrome may be a separate issue.

Comment 10

6 years ago
https://github.com/mozilla/zamboni/commit/9b44bd

... this fixes the /false issue in nightly. The celery issues seem to be not happening anymore. Is there anything else to do on this one?
(Assignee)

Comment 11

6 years ago
I'm pretty sure that this is fixed.

http://cl.ly/image/2T2h2u2b080a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

6 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/ on FF19 (Win 7)
Postfix screencast http://screencast.com/t/ZtGWktLfK
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.