If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

linux stub installer fails to retrieve XPI packages

VERIFIED DUPLICATE of bug 84492

Status

SeaMonkey
Installer
--
critical
VERIFIED DUPLICATE of bug 84492
17 years ago
13 years ago

People

(Reporter: asa, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
tested with 051608 mozilla linux stub installer.

steps to repro:
1. download stub installer
2. unpack the installer
3. launch the installer
4. chose install directory and installation packages
5. click install button

results:  
a console full ofGtk-CRITICAL **: file gtkprogress.c: line 518
(gtk_progress_set_percentage): assertion `percentage >= 0 && percentage <= 1.0'
failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

additional info: a quick test of the 051008 mozilla linux stub installer was
working.

Comment 1

17 years ago
over to samir.
Assignee: ssu → sgehani
(Assignee)

Comment 2

17 years ago
Asa,
Where did you get the installer from: sweetlou or ftp.mozilla.org?  Both places
appear to have the xpi directories populated.  I can't repro this with a
sweetlou build.

Grace,
Can you repro this with a ftp.mozilla.org build?  How about a sweetlou build?
(Assignee)

Comment 3

17 years ago
CC'ing Grace so she can read my last request.

Updated

17 years ago
QA Contact: gemal → gbush

Comment 4

17 years ago
sweetlou installer is working for recommended setup type- failing with a
621error while installing java

mozilla.org installer is hanging on some downloads.
I do not see error messages in console but download process hangs for certain
installs. I was successful with a Navigator only, Nav and mail, nav,mail,spell
and qfa 
(Assignee)

Comment 5

17 years ago
Grace,
Specifically what component does it claim it is downloading when itappears to
hang (it may be timing out on a non-existent xpi).  Thanks.

Is this reproducible with earlier builds from ftp.mozilla.org?
The java failure is because recent jre.xpi files are 858 bytes -- only an 
install script, no actual java. That's a build problem that should be filed as 
a separate bug.

Comment 7

17 years ago
I saw this error yesterday with the ftp.mozilla.org stub installer although it
appeared to install everything (didn't try the java).
(Reporter)

Comment 8

17 years ago
I don't test sweetlou builds so I don't know what's happening there.  I do know
that the mozilla stub builds seemed fine to me all of last week.  I didn't test
it monday or tuesday (I don't think) and when I tried it today I got failures. 
After about 15 tries it finally did make the install (while I had my back
turned) Maybe it just didn't want to be watched ;)

Comment 9

17 years ago
hmm, I answered your query yesterday- didn't take!

It hangs on different components- I could not determine one - once I took 
chatzilla
out of the mix, I was able to install.

I don't usually test with stubs from ftp.mozilla.org- I do test with 
MozInstaller
on Linux a few times a week.

Comment 10

17 years ago
adding K'Trina to cc list
upgrading to blocker as now installing with the full bits fails also.
Severity: critical → blocker
Keywords: smoketest
I'll reduce this back to critical, I was able to at least use the full bits to 
get a build loaded.
Severity: blocker → critical
(Assignee)

Comment 13

17 years ago
Tracy,
What build?  From where are you downloading?  sweetlou or ftp.mozilla.org?  I
haven't changed anything in the download code.  Don't know why this is a
blocker.  Looking...
Tracy is seeing a different bug: jre.xpi and flash.xpi not installing. We will go 
mark those as commercial-only blockers.  He is able to successfully download the 
other bits though so the issue he is seeing is different than this.  (Samir on 
Tracy's computer.)  Removing smoketest keyword.
Keywords: smoketest

Comment 15

17 years ago
I see this with the 2001-06-06-21 build (from ftp.mozilla.org). The 

"Gtk-CRITICAL **: file gtkprogress.c: line 518
(gtk_progress_set_percentage): assertion `percentage >= 0 && percentage <= 1.0'
failed."

messages seem to come from the progress meter. It goes up to 100% and then
continous to download (that's when the error messages begin to appear).
Therefore beeing over 100% => assertion failes.

But I don't think it has anything to do with the bug that follows then: During
the installation I always get the error message that the installation of one xpi
failed, it doesn't tell which. The install.log says that browser.xpi didn't
succesfully install. It fails with error -202, is this a quota problem? If yes,
the installer should say so.

Comment 16

17 years ago
Oh, I forgot something. I tried to gunzip the installer and I tried to do tar
-xzf, both didn't work. tar -xf just worked fine. Shouldn't it therefor be *.tar
instead of *.tar.gz?
This has been triaged and claimed by Leaf in bug 84492.  Read that bug for
details.  Marking dupe.


*** This bug has been marked as a duplicate of 84492 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 18

16 years ago
verified

Comment 19

16 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.