Can not override the charset on some pages that with meta-tag

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
18 years ago
18 years ago

People

(Reporter: amyy, Assigned: shanjian)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 05-15 trunk, also reproduce on N6.01

Steps to reproduce:
1. Loading some Japanese or Chinese pages, you will see they are display fine.
e.g. http://www.mainichi.co.jp(s-jis) and http://www.singtao.com(no meta charset, most likely Big5-HKSCS), 
2. Set Auto-Detect OFF
3. Change charset to some wrong charsets, e.g. Western 8859-1, EUC-KR, Aribic ...

Result:
1.You will see no matter what kind charset that you choose, the page just won't get garbled (display fine) 
except the characters in Title bar will change.
2. The charset will marked follow by what you choosing (wrong charset).  
So even the charset was marked as Aribic, the page itself will display as Japanese or Chinese.
(Reporter)

Comment 1

18 years ago
Add intl keyword and assign to shanjian.
Assignee: nhotta → shanjian
Keywords: intl
QA Contact: andreasb → ylong
(Assignee)

Comment 2

18 years ago
Yuying, if you check the page source, you will see that those 2 web pages have frames. 

The mail page charset in fact is set correctly, and reflected in charset menu. Child 
frame inherit the charset from their parents, but those charset can be override by 
meta tag charset (or even auto-detection). Since we have to allow child frame using 
a charset different from its parents, we have to accept that. Unless we allow use to 
apply forced charset/charset detection to frame individually, that seems to be the 
best behavior we can get. (If autodetection is set and it return a different charset 
from its parents, that's even worse.) Any way, we almost can do nothing now. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

18 years ago
Mark it as verified according shanjian's comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.