Closed Bug 812468 Opened 7 years ago Closed Last year

Bidi issue in placeholder text in Firefox quick searchbox

Categories

(Firefox :: Search, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: mounir, Unassigned)

References

Details

(Keywords: rtl)

Attachments

(1 file)

Attached image Screenshot
I was testing a bug with RTL and I realized this bug (using Firefox 16). You can see that the "Wikipedia (en)" has been cut and we only see "Wikipedia (en". In LTR, the full placeholder is shown.

See the attached screenshot.
If you look carefully, you'll see that the second paranthesis is not cut off, but shown at the left side of thw word, i.e. left to the letter 'W'. This is a bidirectionality issue, since the textbox in question is RTL-directed and will always put ending punctuations (and paranthesis) at the end of the line (which happens be the leftmost of the line from RTL perspective).

I don't know whether it is possible to apply bidi for such textboxes to avoid this issue.
Keywords: rtl
Summary: When Firefox UI is in RTL, the search toolbar cuts some text → Bidi issue in placeholder text in Firefox quick searchbox
The parenthesis appears wrong because of the text direction. As having en-US layout with direction:rtl isn't an expected behavior other than to help reproducing RTL bugs, I am not sure if we need to change something in the code. 

Bug 425686 was about similar issue and we've fixed the situation by making sure the placeholder text won't mix between RTL and LTR characters.
I actually found that bug with parenthesis in a few places in the chrome UI (like the about page). I'm fine with having this bug marked as invalid.
We can probably add a LRM to the end of those strings...
(In reply to Ehsan Akhgari [:ehsan] from comment #4)
> We can probably add a LRM to the end of those strings...

Won't dir=auto be a better solution?
(In reply to Tomer Cohen :tomer from comment #5)
> Won't dir=auto be a better solution?
+1
Once we get support for it (very soon), sure!
Depends on: 869833
We no longer show the search engine name in the search bar.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.