"tagging started" mail not getting sent to release-drivers list anymore

RESOLVED WONTFIX

Status

Release Engineering
Release Automation: Other
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Strangely, this mail is still making it through to release@mozilla.com (and presumably, release-mgmt@mozilla.com).

I see log messages on the master indicating that mail is being sent:
2012-11-16 05:19:16-0800 [Broker,69969,10.26.74.22] sending mail (384 bytes) to ['<release-drivers@mozilla.org>']

CC'ing some release-drivers admins so we can make sure the mails aren't getting filtered or otherwise stuck in mailman.
(Reporter)

Comment 1

6 years ago
Also wondering if maybe it's getting spam filtered. Dave, is release-drivers mail is subject to postini or other spam filters? If so, are there any "Tagging started" mails trapped in it?
Where is the mail being sent to? (what smtp server?)  If it's using smtp.mozilla.org, then no, it shouldn't be going through postini.  It will go through postini if you're using the public MX records to deliver it.

release-drivers is a mailman mailing list, which also has its own moderation queue.  I see nothing in that queue currently.  jbecerra, dveditz, akeybl, and johnath are all set up to receive notification any time something gets stuck in that queue.

I see nothing other than real spam dated within the last week in the postini quarantine for that address.
Also of note: Zimbra will remove duplicate messages.  If you are a member of multiple lists that would receive this message, you will only get it on one of them because Zimbra will remove the rest as duplicates on the receiving end.
(Reporter)

Comment 4

6 years ago
(In reply to Dave Miller [:justdave] from comment #3)
> Also of note: Zimbra will remove duplicate messages.  If you are a member of
> multiple lists that would receive this message, you will only get it on one
> of them because Zimbra will remove the rest as duplicates on the receiving
> end.

Hrm. I bet that's it. Is that new-ish behaviour? I have the mail I would expect as recently as 10/17/12 10:15 AM.
No, it's always been that way for as long as we've been using Zimbra.  It is, however, totally random.  Which one gets kept depends on which one shows up first.

That behavior is also configurable in Zimbra (globally) and I hate it and wish we could turn it off, because it hoses my filters and causes issues exactly like this.  Every time the subject is brought up, I get shot down because people want their duplicates deduped apparently.
see also bug 430518 for some history on that.
Sooo, assuming we don't want to morph this bug to be a "fix zimbra" bug, I'm going to reso/wfm

Since I just checked my @gmail.com r-d mail and I do see the tagging-started for fennec b7 there.

However as Dave does say, and you also see, it is indeed missing from my @mozilla.com zimbra inbox. I do also wish it wasn't so, and have seen it many times where it indeed wasn't.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

6 years ago
Even if this isn't an IT issue, I want to find out what changed -- I was getting all the mail I would expect until recently.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
As we verified via archives and other list members that the mail did actually go to the list, the likelihood that Zimbra's duplicate detection was at fault is pretty high.  The duplicate detection will keep the first copy of a message that it receives, and discard any others with the same Message ID that come in later.  This makes it essentially entirely random which one you end up keeping because the order they're received won't necessarily be the same every time.  There are any number of factors in the process of getting mail from one place to another that could affect the delivery order.
(Reporter)

Comment 10

6 years ago
I think bug 683725 may have made the difference here. It caused release mail to be threaded by adding In-Reply-To and References. I'm guessing that that affected how Zimbra processes it.
(Reporter)

Comment 11

6 years ago
Happy to close this now that I'm pretty sure I know what the cause was. I filed bug 814428 about getting zimbra deduping turned off, even though it's unlikely to happen.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.