Broken keyboard accessibility in the Web Console

RESOLVED DUPLICATE of bug 588010

Status

P3
normal
RESOLVED DUPLICATE of bug 588010
6 years ago
3 months ago

People

(Reporter: msucan, Unassigned)

Tracking

({access})

Trunk
access

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Tried to use the Web Console with the keyboard only. Found the following:

1. If I focus the output, by clicking one of the messages, I would expect to press Tab once to jump into the JavaScript input field. What actually happens: Tab goes through each of the message location links, starting from the top. This makes jumping to the JS input hard by Tab.

2. Try to use the filter drop downs: no Alt+key combinations and you cannot Tab to those buttons.

3. Try to use the Position drop down or the Clear button. Same problem as above.

4. Tabbing through the output is inconsistent: Tab-based navigation doesn't focus inspectable objects or network requests, so you cannot activate any of these.

I would propose:

1. Make buttons focusable, so users can tab to them.
2. Make objects and network requests in the output focusable.
3. Find a way to avoid having to tab through each focusable output item, when you just want to jump to the JS input. I think we could do a special case here: if no output item has focus, but the output itself is focused, pressing tab jumps to the input. If you are otherwise focusing an element in the output - like an object - tab jumps to the next focusable thing inside the output.

If anyone has thoughts, please comment. Thanks!
(Reporter)

Comment 1

6 years ago
Almost a duplicate...
Blocks: 584121
Priority: -- → P3
(Reporter)

Comment 2

5 years ago
The proposed points 1 and 2 from comment #0 are now implemented. Point 3 is related to making the console behave more like a terminal rather than having it require users to focus the input field.

Marking this bug as a duplicate of bug 588010 which seems to closer match my initial intents.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588010

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.