Style Editor doesn't always open for CSS warnings

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 months ago

People

(Reporter: msucan, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The way the style editor is integrated into the web console only works if:

- the CSS warning comes from a stylesheet in the top level content window. no support for iframes.
- the stylesheet address contains no ?parameters. And this is where it gets tricky - I saw CSS warnings coming with their sourceName stripped - no ?parameters, and I don't know why. Now I cannot reproduce this.

Needs more investigation.
(Reporter)

Comment 1

5 years ago
Style Editor now works with iframes - bug 740541. Also, tested styles with ?paramaters and they work for me now. It might have been an issue related to the build I had at the time of the bug report.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.