[Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) with Asus Gamer OSD

VERIFIED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Core
Graphics
--
critical
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Robert Kaiser, Assigned: bsmedberg)

Tracking

(Blocks: 1 bug, {crash, reproducible})

unspecified
mozilla27
x86
Windows 7
crash, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17+ wontfix, firefox18+ wontfix, firefox19+ wontfix, firefox20+ wontfix, firefox21 wontfix, firefox22 wontfix, firefox23 wontfix, firefox24 wontfix, firefox25 wontfix, firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [startupcrash], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-ac0190a0-8947-47fe-b443-98c412121116 .
============================================================= 

This is a new startup crash across multiple Firefox versions, at least 14 through 18 are affected. The stack has a ton of d3d11.dll and d2d1.dll frames on top, with _d2d_clear_surface being the first frame in our own code.

The comments seem to suggest that this is happens after installing IE10, and all those crashes are on Win7, which AFAIK just got IE10 very recently.

See https://crash-stats.mozilla.com/report/list?signature=RtlpAllocateHeap%20|%20RtlpAllocateHeap%20|%20d3d11.dll%400x7c1f for more crashes, comments, etc.


As IE10 for Win7 is very new, we should test with that installed and see if it generally breaks Firefox (most of the reports right now are with 16.0.2 and the last 17 betas, so let's concentrate on those, esp. 17).
(Reporter)

Comment 1

5 years ago
This is quite low volume right now, but if it indicates that Win7 with the just released IE10 preview always crashes Firefox at startup, we should see if we can do something about that, therefore nominating for both 18 and even 17.
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
I'll be sure to instruct Softvision to have IE10 installed when testing 17RC builds.
OS: Windows NT → Windows 7
I installed the IE 10 Preview on one QA lab machine running Win 7, using the latest FF 17 beta. So far have not generated any crashes.

Since this is so low volume, perhaps some manual correlations may lead us to a trail - some of the users did have various extensions installed. One person mentioned they had just updated Adobe and IE 10.

Comment 4

5 years ago
I think it's the Windows 7 version of bug 806346 (same Firefox frames in the stack trace).
Whiteboard: [startupcrash]
(Reporter)

Comment 5

5 years ago
(In reply to Marcia Knous [:marcia] from comment #3)
> I installed the IE 10 Preview on one QA lab machine running Win 7, using the
> latest FF 17 beta. So far have not generated any crashes.

OK, good to know it doesn't affect everyone. Unfortunately it of course doesn't explain when this happens, though. I guess we need to keep watching and testing.

(In reply to Scoobidiver from comment #4)
> I think it's the Windows 7 version of bug 806346 (same Firefox frames in the
> stack trace).

That could very well be the case.

Comment 6

5 years ago
(In reply to Marcia Knous [:marcia] from comment #3)
> I installed the IE 10 Preview on one QA lab machine running Win 7, using the
> latest FF 17 beta. So far have not generated any crashes.
Is the GPU compatible DirectX 10 or 11 (dxdiag log)? You should find a computer with a DirectX-11 GPU.
Given the current low-volume and that it hasn't been hit yet in testing, there's nothing we can do for 17 - especially if this is the win7 version of bug 806346 which we do not have a fix for yet anyway.  Will track for 18/19 and hopefully we'll find some new avenues of investigation.
status-firefox17: --- → wontfix
status-firefox18: --- → affected
status-firefox19: --- → affected
tracking-firefox17: ? → +
tracking-firefox18: ? → +
tracking-firefox19: --- → +

Updated

5 years ago
QA Contact: ioana.budnar

Comment 8

5 years ago
The Firefox 17.0 RC build (20121116115405) was tested for about 6-7 hours on Windows 7 SP1 32bit and Windows 8 64bit with IE10 installed and intermittently used, left open etc. No crashes occured.

I also performed some dogfooding on this build, on Windows 7 SP1 32bit, after installing IE10 and using it/closing it intermittently. Still no crashes.
I run IE10 as well without issues. The IE10 install -does- however update Direct2D. So we should keep a very close eye on this as this is not unlikely to get worse.

Updated

5 years ago
Summary: Win7 startup crash in d3d11.dll (after installing IE10?) → Win7 startup crash in _d2d_clear_surface @ d3d11.dll (after installing IE10?)
Dogfooding has not been successful in identifying steps to reproduce this crash. Is there any information to help target QA's testing?
QA Contact: ioana.budnar
(Reporter)

Comment 11

5 years ago
This remains low volume, but also happens with 17 release.

Comments from the last 4 weeks:

esto ducedio desde haber instalado internet explore 10 no se si ese sea el motivo por favor ayudenme
(Google translation: ducedio have installed it from internet explore 10 not know if this is the reason please help)
Submitted: 2012-11-15T14:40:27+00:00

Unstalled IE 10 and now firefox wont start
Submitted: 2012-11-20T01:44:16+00:00

После установки Explorer 10 для Windows 7 Mozilla 16.2 не запускается. Что делать?
(Google translation: After installing the Explorer 10 for Windows 7 Mozilla 16.2 does not start. What to do?)
Submitted: 2012-11-19T11:14:35+00:00

Firefox started crashing, and runs only in safe mode, after installing IE10 Preview on Win 7 64bit
Submitted: 2012-11-19T12:52:17+00:00

Crash after installinf IE 10 and adobe flash player
Submitted: 2012-11-13T21:57:44+00:00

crashed after installing Explorer 10
Submitted: 2012-11-19T11:25:02+00:00

(I excluded some comments that were not telling anything useful at all.)


So far, the crash is too low volume to produce any correlations. It's still 100% Windows and 100% startup.
(Reporter)

Comment 12

5 years ago
https://crash-stats.mozilla.com/report/list?signature=d3d11.dll%400xe6313 is another Win7-only startup issue in d3d11.dll, may be related.
(Reporter)

Comment 13

5 years ago
Adding the same addess of d3d11.dll directly as we've seen that as a signature as well. And there's more d3d11.dll crashes, mostly on startup: https://crash-stats.mozilla.com/query/query?product=Firefox&version=ALL%3AALL&query_type=contains&query=d3d11.dll&do_query=1

Ted, I thought we would pull all MS symbols from their servers, why don't we have them for this one?

Here's the DLL info including the debug ID:
d3d11.dll 	6.2.9200.16440 	2E7D1CBB3B5C44F9B9034FE6B8FAC3C31 	d3d11.pdb
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f] → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f] [@ d3d11.dll@0x7c1f]
I don't see any obvious reason except that this must be a new version of that library, and it only showed up in crash reports a day or two ago and we just haven't picked it up yet. Looks like it should get picked up tonight. (I'll force a manual run of the symbol fetching script to pick it up.)
(Reporter)

Comment 15

5 years ago
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #14)
> I don't see any obvious reason except that this must be a new version of
> that library, and it only showed up in crash reports a day or two ago and we
> just haven't picked it up yet. Looks like it should get picked up tonight.
> (I'll force a manual run of the symbol fetching script to pick it up.)

Thanks. It's not the last one or two days, this signature first was seen two weeks ago.
Dropping qawanted as we've been unable to find steps to reproduce. If someone can provide further details to help QA do more focused testing please re-add qawanted.
Keywords: qawanted → steps-wanted
(Reporter)

Comment 17

5 years ago
Ted, we're still getting this, could you check if we actually did retrieve symbols for this?

Still, this is pretty low volume so might not need to be tracked.
For some reason this symbol wasn't downloaded by the symbol fetching script. I'll look into that in the near future, but for now I've manually uploaded the symbol file in question.
(Reporter)

Comment 19

4 years ago
We now seem to get symbols for those, but now I need to connect the new signatures to the old ones. For that's I'd like three reports of both the signatures on this bug to be reprocessed:

[@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f]
bp-5085fc21-2792-4f92-8e1d-62b692121204
bp-1addbd35-c59d-4010-9ff2-30e702121205
bp-009ea6d0-64bb-4171-8527-7bf772121205

[@ d3d11.dll@0x7c1f]
bp-774a30c7-4b77-47fc-8b6c-901772121205
bp-2934ddc6-e36c-4595-92b8-8eede2121205
bp-45fa53f7-fe61-4bfd-8540-0c8582121201
(Reporter)

Comment 20

4 years ago
Thanks to lars for reprocessing those, adding the new signatures. Bas, do the new stacks help us understand the problems?
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f] [@ d3d11.dll@0x7c1f] → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f] [@ d3d11.dll@0x7c1f] [@ RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*) ] [@ CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*) ]
(Reporter)

Updated

4 years ago
Summary: Win7 startup crash in _d2d_clear_surface @ d3d11.dll (after installing IE10?) → Win7 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing IE10?)

Comment 21

4 years ago
When an problem encountered probably after installing IE10 or updating to the latest nvidia driver, which makes my 17.0.1 32bit firefox unable to use hardware acceleration(win7 64bit), but I found that when using 64bit firefox v20 with hardware acceleration enabled leaves no problem, so maybe the bug is caused by something related to architecture?
(Reporter)

Comment 22

4 years ago
jlgdot369, can you give us the exact nvidia driver version this is happening with, as well as the type of graphics card? Also, can you go to about:crashes and find the ID of the crash report generated at the time this issue occurred?
Do you remember what exactly you did to trigger the crash?

Comment 23

4 years ago
I've tried both nVIDIA WHQL V306.23 with firefox x64(palemoon v15), and nVIDIA WHQL V310.70 with firefox v20.0a1 x64, which in about:support pages says hardware acceleration is enabled, which solves my crash problem.
The crash I've encountered happens maybe after IE10 installation or an recent windows7 update which reads "nvidia graphics driver wddm1.1 graphics adapter wddm1.2, other hardware - nvidia geforce GTX 560Ti" with nVIDIA WHQL V309.
The crash happens with firefox v17.0.1 which have acceleration enabled by default, when I open firefox it say crash, and want me to report. Crash ID 62a8a334-d172-4ecf-9cc8-e3d4e2121210.
(Reporter)

Comment 24

4 years ago
I'd like to see what's coming out of bug 823077 comment #18, maybe there actually is some connection here.
We could reach to MS I think. I can't reproduce this and I don't see how the cause can be on our side. I really don't have many ideas for what else to try, the stack trace might be more useful once we have the new d2d1.dll symbols. But I seriously doubt it.
(Reporter)

Comment 26

4 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #25)
> We could reach to MS I think.

If we have enough useful information for them (i.e. someone can pull that together) and a good contact, I'm all for that. Bug 819028 is another case where that might make sense.
I'm going to reach out to a contact at MS about these crashes, since we don't think there's any more info we can collect on our side.
(In reply to Alex Keybl [:akeybl] from comment #27)
> I'm going to reach out to a contact at MS about these crashes, since we
> don't think there's any more info we can collect on our side.

I've sent email to MS, nothing to do here for FF19
status-firefox18: affected → wontfix
status-firefox19: affected → wontfix
tracking-firefox20: --- → +
Milan, can you follow up on this? I hear you are in conversation with MS.
Assignee: nobody → milan
We are talking to MS, but we've pushed them to work on Bug 830531 as a priority, though that one appears to be more of an AMD.  Last was, though, them asking for an STR, but I don't think we have that.

Comment 31

4 years ago
With the release of KB2670838 for all Windows 7 users not only for those who have installed IE 10, there's a spike in startup crashes and it's currently #15 top browser crasher in 19.0 and #14 in 20.0b1 with an upward tendency.

Two users have already reported that in the French support forum: http://forums.mozfr.org/viewtopic.php?f=5&t=111577, http://forums.mozfr.org/viewtopic.php?f=5&t=111582

Disabling HW acceleration fixes the issue.
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f] [@ d3d11.dll@0x7c1f] [@ RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*) ] [@ CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*) ] → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ d3d11.dll@0x7c1f ] [@ d3d11.dll@0xe6314 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int&hellip;
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
Keywords: topcrash
Summary: Win7 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing IE10?) → Win7 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838)

Comment 32

4 years ago
For some reasons, it affects only AMD and NVIDIA GPUs, not Intel ones.
A note from Microsoft:

They recommend running the Windows 7 App Verifier on a machine that is having this issue (find it at http://www.microsoft.com/en-us/download/details.aspx?id=20028 ). From the crash dump, it appears the heap is being corrupted, but it’s not clear if D3D or the graphics driver is corrupting the heap. Since the majority of crash reports are on nVidia hardware, we’re tentatively thinking it’s the graphics driver. Can you look into this more?

Comment 34

4 years ago
Reported here too: http://forums.mozillazine.org/viewtopic.php?f=23&t=2669153
Duplicate of this bug: 845891
Adding qawanted to test Firefox with Win7/KB2670838 on our available configs. Based upon comment 34, we should be looking for something similar to a dual-GPU config Nvidia 560 GTX TI and Intel graphics with a driver version of 9.18.13.697.
Keywords: qawanted
(In reply to Loic from comment #34)
> Reported here too: http://forums.mozillazine.org/viewtopic.php?f=23&t=2669153

We've also requested that a known impacted user try http://www.microsoft.com/en-us/download/details.aspx?id=20028

Comment 38

4 years ago
Created attachment 719171 [details]
Application verifier log: HW on (crash), HW off (no crash)

Comment 39

4 years ago
The log comes from a user commenting in http://forums.mozfr.org/viewtopic.php?f=5&t=111577&p=723456#p723456

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ d3d11.dll@0x7c1f ] [@ d3d11.dll@0xe6314 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;

Comment 40

4 years ago
Uninstalling the Windows update will temporarily fix this problem. 
I'm running a single card Nvidia 560. Crash happened after reboot of Windows update KB2670838. Doing an Nvidia graphics update temporarily fixed the problem until I rebooted, than it started crashing on start up also. Updated FF 20 beta. Same problems. Uninstalled the update and restarted, Firefox starts up great. Now I'm sitting here with windows telling me that it wants to reinstall the update again.

Comment 41

4 years ago
Crashes happened using GeForce 306.97 Drivers. Updating them to GeForce 314.07 Driver temporarily fixed the problem until the computer was started.

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
(In reply to grkmanga49 from comment #40)
> I'm running a single card Nvidia 560. 

I'm going to attempt to reproduce this on my Nvidia 8600GT. In the meantime, could you please tell me specifically which card you have (brand and a model number would be great)? Purchasing the same model of card might be the only way we reproduce this.
Trying to work through @grkmanga's steps with an NVidia 8600GT in Windows 7.

1. Download and install GeForce 306.97 then restart computer
2. Ensure DirectX11 and IE10 are installed
2. Start Firefox 20.0b1 and ensure HWA is turned on
3. Browse around to some common websites for 15 minutes, restarting Firefox every few minutes
> No crash
4. Download and install KB2670838 then restart computer
5. Start Firefox 20.0b1 and continue browsing
6. Browse for 15 minutes restarting every few minutes
> No crash
7. Download and install GeForce 314.07 then restart computer
8 Start Firefox 20.0b1 and continue browsing
9. Browse for 15 minutes restarting every few minutes
> No crash

Sadly, I think we will need to track down the same card as grkmanga once we get more details on the specific model.

In the meantime, would it be possible to get correlation data for specific chipsets? Purchasing the highest correlated chipset is likely to improve the success rate.

Comment 44

4 years ago
My Firefox is crashing at start-up and the crash report link me to this site. After reading this throw here, is likely cause my problem as the win7 update KB2670838 was installed the same day the problem did occur. crash ID: bp-a79cf127-b9bc-4be9-9a5e-8b6052130228

I am running:
- Win7 home edition Norwegian, Firefox 19
- Graphic card: Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97
http://www.asus.com/Graphics_Cards/ENGTX5702DI1280MD5/
- Motherboard: Asus P8Z68-V PRO, with Intel i7-2600K
http://www.asus.com/Motherboard/P8Z68V_PRO/

I updated GeForce to 314.07, and same as "grkmanga49" I was able to use firefox until next reboot. I did then uninstall KB2670838, and Firefox start as normal.

Hope this can be helpful.

Comment 45

4 years ago
(In reply to Marius from comment #44)
> I did then uninstall KB2670838, and Firefox start as normal.
If you want to keep this update (required to run IE 10), turn off Firefox HW acceleration (not WebGL): https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_turning-off-hardware-acceleration

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;

Comment 46

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #42)
> (In reply to grkmanga49 from comment #40)
> > I'm running a single card Nvidia 560. 
> 
> I'm going to attempt to reproduce this on my Nvidia 8600GT. In the meantime,
> could you please tell me specifically which card you have (brand and a model
> number would be great)? Purchasing the same model of card might be the only
> way we reproduce this.

ASUS ENGTX560 DCII OC/2DI/1GD5 GeForce GTX 560 (Fermi) 1GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card 

IGABYTE GA-EP45-UD3R LGA 775 Intel P45 ATX Intel Motherboard 

May be an Asus Graphics card problem. Who knows, we need more information :/

Updated

4 years ago
Summary: Win7 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) → Win7/8 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838)

Comment 47

4 years ago
https://crash-stats.mozilla.com/report/index/bp-28c5cb68-4862-4b6a-9a3d-1d8882130301

AMD Radeon HD 6700 Series

My IE9 is crashing now as well. :-(

Comment 48

4 years ago
Actually I think that crash is different, but I also have this one (https://crash-stats.mozilla.com/report/index/bp-88439c6c-2c0e-4d0b-85fc-ef99f2130301).
(In reply to grkmanga49 from comment #46)
> ASUS ENGTX560 DCII OC/2DI/1GD5 GeForce GTX 560 (Fermi) 1GB 256-bit GDDR5 PCI
> Express 2.0 x16 HDCP Ready SLI Support Video Card 

Thank you for sharing this information. I've now ordered this card; expecting delivery by Tuesday.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #49)
> (In reply to grkmanga49 from comment #46)
> > ASUS ENGTX560 DCII OC/2DI/1GD5 GeForce GTX 560 (Fermi) 1GB 256-bit GDDR5 PCI
> > Express 2.0 x16 HDCP Ready SLI Support Video Card 
> 
> Thank you for sharing this information. I've now ordered this card;
> expecting delivery by Tuesday.

Bad news...

This card is no longer available. It seems that NVidia is no longer shipping the GTX 560 chipset. We'll need to try to identify a currently available chipset which is relatively high in the correlation data.

Please advise.
Follow-up to my previous comment. 

Before ordering the card it was "out of stock" at many vendors and I only found it "available" at one place. This vendor has just called me to confirm they are out of stock as well and this was misreported on their website. They have canceled the order, so we'll have to find something else.

Comment 52

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #50)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #49)
> > (In reply to grkmanga49 from comment #46)
> > > ASUS ENGTX560 DCII OC/2DI/1GD5 GeForce GTX 560 (Fermi) 1GB 256-bit GDDR5 PCI
> > > Express 2.0 x16 HDCP Ready SLI Support Video Card 
> > 
> > Thank you for sharing this information. I've now ordered this card;
> > expecting delivery by Tuesday.
> 
> Bad news...
> 
> This card is no longer available. It seems that NVidia is no longer shipping
> the GTX 560 chipset. We'll need to try to identify a currently available
> chipset which is relatively high in the correlation data.
> 
> Please advise.

Check here: http://www.amazon.fr/Asus-ENGTX560-DCII-TOP-1GD5/dp/B004KW5ARC
(In reply to Loic from comment #52)
> Check here: http://www.amazon.fr/Asus-ENGTX560-DCII-TOP-1GD5/dp/B004KW5ARC

I'm in Canada and can only order from amazon.ca. This card is not in stock on amazon.ca, nor is it in stock on amazon.com (for my American counterparts).
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #53)
> (In reply to Loic from comment #52)
> > Check here: http://www.amazon.fr/Asus-ENGTX560-DCII-TOP-1GD5/dp/B004KW5ARC
> 
> I'm in Canada and can only order from amazon.ca. This card is not in stock
> on amazon.ca, nor is it in stock on amazon.com (for my American
> counterparts).

I can however order the Asus Geforce Gtx 560 Ti but I'm not sure if there is an architectural difference between the Ti and non-Ti cards. These cards are not a trivial expense (~$300) so I'd like to know chipset correlation before I sink that kind of money into something which may or may not reproduce this issue.

Comment 55

4 years ago
Both the GTX 560 Ti and the 560 is from the same chip, GF114. The 560 Ti has all functional SM units enabled & 560 has 1 SM unit disabled because of defects or for yields.

Nvidia has long discontinued the GF114 GPU production and replaced it with the newer Kepler GTX 660 Ti(GK104 GPU) & GTX 660(GK106 GPU).

I would suggest not purchase these discontinued cards. Instead you should contact Nvidia on their forums and refer them to this bug instead so they can figure it out and fix it if it's a bug in the drivers.

https://forums.geforce.com/default/board/33/geforce-drivers/

Comment 56

4 years ago
(In reply to Marius from comment #44)
> My Firefox is crashing at start-up and the crash report link me to this
> site. After reading this throw here, is likely cause my problem as the win7
> update KB2670838 was installed the same day the problem did occur. crash ID:
> bp-a79cf127-b9bc-4be9-9a5e-8b6052130228
> 
> I am running:
> - Win7 home edition Norwegian, Firefox 19
> - Graphic card: Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce.
> 306.97
> http://www.asus.com/Graphics_Cards/ENGTX5702DI1280MD5/
> - Motherboard: Asus P8Z68-V PRO, with Intel i7-2600K
> http://www.asus.com/Motherboard/P8Z68V_PRO/
> 
> I updated GeForce to 314.07, and same as "grkmanga49" I was able to use
> firefox until next reboot. I did then uninstall KB2670838, and Firefox start
> as normal.
> 
> Hope this can be helpful.

Got any other graphics card you can swap in atm to see if Firefox works with the update?

Comment 57

4 years ago
(In reply to grkmanga49 from comment #56)
> 
> Got any other graphics card you can swap in atm to see if Firefox works with
> the update?

Yes I got a Sapphire ATI HD Radeon HD4870, but still Firefox crash with this one.

-I removed Asus graphic card and installed ATI card with driver and Started Firefox all ok.
- Installed the KB2670838 update, and started Firefox, but it crashed. ID: bp-941c28d2-9f48-43af-96b9-336d42130302
- Uninstalled NVidia Driver and software, rebooted, but still Firefox crashed. ID: bp-52cf4b4b-1687-4302-ba01-66fdb2130302

Next I was about to check which DirectX version I had in case there was an update;
-I Ran DirectX-diagnostic tool, but it did also crash. When I started it again a window pop-up stating that the DirectX 3D driver caused the diagnostic tool to crash and I could run diagnostic without the 3D driver. That did work.
- I then got the option in the diagnostic tool to run in 64-bit which it did run without crashing.
- I then installed the 64-bit version of Firefox, Nightly. This did run perfect with the KB2670838 update installed.
- Next I uninstalled the KB2670838 update and run the DirectX-diagnostic tool in 32-bit, and it did not crash then.

Possibly the problem then is with the 3D DirectX 11 which won't run on 32-bit software?

Comment 58

4 years ago
There are crashes in 19.0.1 but Windows 8 is unaffected.
Summary: Win7/8 startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) → [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838)
(Reporter)

Comment 59

4 years ago
Yes, all in all this and bug 819028 are both Win7-only.
We are talking to AMD (mostly) and Microsoft (somewhat) about this.
QA Contact: anthony.s.hughes
QA is still trying to track down on-market hardware that reproduces this crash. Can someone please come back to us with correlations to specific chipsets so we can do some market research?

Comment 62

4 years ago
Marius:
    Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97
grkmanga49:
    ASUS ENGTX560 DCII OC/2DI/1GD5 GeForce GTX 560 (Fermi) 1GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card
Glen A.:
    ASUS AMD Radeon EAH6770 DC/G/2DI/1GD5 (http://www.asus.com/Graphics_Cards/EAH6770_DCG2DI1GD5/)
    
All ASUS so far.

You can purchase my card here (1 left in stock): http://www.amazon.com/DirectCU-EAH6770-DC-2DI-1GD5/dp/B00576Y31E/ref=sr_1_fkmr0_2?ie=UTF8&qid=1362764961&sr=8-2-fkmr0&keywords=EAH6770+DC%2FG%2F2DI%2F1GD5

Mine has a "G" in it though: DC/G/2DI/1GD5 vs DC/2DI/1GD5

... probably the same or very similar.
(Reporter)

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
(In reply to Glen A. from comment #62)
> Marius:
>     Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97

If you update your graphics drivers, does this continue to reproduce? (same question goes to anybody else running into this crash)

We'll look into ordering similar hardware.

Comment 64

4 years ago
Can Nvidia users please test the latest 314.21 beta drivers and see if it helps?

http://www.nvidia.com/object/win8-win7-winvista-32bit-314.21-beta-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-314.21-beta-driver.html

Notebook drivers
http://www.nvidia.com/object/notebook-win8-win7-314.21-beta-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-314.21-beta-driver.html

Comment 65

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #63)
> (In reply to Glen A. from comment #62)
> > Marius:
> >     Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97
> 
> If you update your graphics drivers, does this continue to reproduce? (same
> question goes to anybody else running into this crash)
My driver software is up-to-date already, according to Windows.
(In reply to Glen A. from comment #65)
> (In reply to Alex Keybl [:akeybl] from comment #63)
> > (In reply to Glen A. from comment #62)
> > > Marius:
> > >     Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97
> > 
> > If you update your graphics drivers, does this continue to reproduce? (same
> > question goes to anybody else running into this crash)
> My driver software is up-to-date already, according to Windows.

Please see comment 64 to test the latest. Thanks Glen :)

Comment 67

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #63)
> (In reply to Glen A. from comment #62)
> > Marius:
> >     Asus Nvidia GeForce GTX 570 (ENGTX570/2DI/1280MD5), GeForce. 306.97
> 
> If you update your graphics drivers, does this continue to reproduce? (same
> question goes to anybody else running into this crash)
> 
> We'll look into ordering similar hardware.

I am sorry to say that I am working offshore for and don't have access to my computer for the next 3 weeks to test this.

Comment 68

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #66)
> Please see comment 64 to test the latest. Thanks Glen :)
I don't have an Nvidia card (mine is AMD).

Comment 69

4 years ago
Nvidia released GeForce 314.22 WHQL drivers.

http://www.nvidia.com/object/win8-win7-winvista-32bit-314.22-whql-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-314.22-whql-driver.html

Notebook drivers
http://www.nvidia.com/object/notebook-win8-win7-314.22-whql-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-314.22-whql-driver.html
(Reporter)

Comment 70

4 years ago
This issue seems to be declining, the driver update mentioned in comment #69 could be related.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #70)
> This issue seems to be declining, the driver update mentioned in comment #69
> could be related.

How are we looking this week?
(Reporter)

Comment 72

4 years ago
Compared to comment #31, we are down a bit, now at #20-#25 depending on version, but it seems to be relatively stable, the effect of what I saw in comment #70 seems not to have been very large.

Comment 73

4 years ago
Still not fixed: https://crash-stats.mozilla.com/report/index/20b49b6a-02ec-4d31-a211-0407e2130404

What did AMD say?

Comment 74

4 years ago
New Nvidia drivers did not solve problem. Does this problem have to do anything with not installing the 3D drivers when installing the new Nvidia drivers?

Mozilla was working fine with Hardware acceleration until Windows 7 forced an "important" Internet Explorer 10 update.

Internet Explorer 10 for Windows 7 for x64-based Systems
That's the update that broke it - again.

More information on the Nvidia drivers. I only install the Graphic drivers and the Physx drivers. I don't install the 3d drivers or Audio HD drivers.
(In reply to grkmanga49 from comment #74)
> New Nvidia drivers did not solve problem. Does this problem have to do
> anything with not installing the 3D drivers when installing the new Nvidia
> drivers?

Could you try installing the 3D drivers to see if it makes a difference?

Comment 76

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #75)
> (In reply to grkmanga49 from comment #74)
> > New Nvidia drivers did not solve problem. Does this problem have to do
> > anything with not installing the 3D drivers when installing the new Nvidia
> > drivers?
> 
> Could you try installing the 3D drivers to see if it makes a difference?

I installed them and Mozilla worked with hardware acceleration until I restarted windows. Once I restarted, I had the same problems. I uninstalled them now, I don't think they are related. Mozilla works with hardware acceleration on a fresh graphic driver install until restarted.

This makes me believe that when the drivers are freshly installed, windows may use the correct files for Firefox to launch properly with hardware acceleration... But when windows is restarted, it resets to some default driver/file that causes Firefox to crash with hardware acceleration. 
Anyway to verify this theory? I think it may have to do with there way to get Internet Explorer 10 working.
(In reply to grkmanga49 from comment #76)
> when the drivers are freshly installed, windows
> may use the correct files for Firefox to launch properly with hardware
> acceleration... But when windows is restarted, it resets to some default
> driver/file that causes Firefox to crash with hardware acceleration. 
> Anyway to verify this theory? I think it may have to do with there way to
> get Internet Explorer 10 working.

That's an interesting theory. Can someone from NVidia confirm whether this is the case?

Updated

4 years ago
Blocks: 861232
Dropping qawanted from this bug since we've had no success trying to find internally reproducible conditions. Please re-add if something actionable comes to light.
Keywords: qawanted
(Reporter)

Comment 79

4 years ago
This (and also bug 819028) has dropped significantly about a week ago in Firefox 20 data and now only this signature has lost roughly a third of the volume it had before. I'm not aware of any Windows Update or driver release around the 14th that could have caused this.

Comment 80

4 years ago
Nvidia has released GeForce 320.00 beta drivers, if anyone wants to test them.

http://www.nvidia.com/object/win8-win7-winvista-32bit-320.00-beta-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-320.00-beta-driver.html

Notebook drivers
http://www.nvidia.com/object/notebook-win8-win7-320.00-beta-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-320.00-beta-driver.html

Comment 81

4 years ago
Here's the latest Nvidia GeForce 320.14 beta drivers, if anyone wants to test them.

http://www.nvidia.com/object/win8-win7-winvista-32bit-320.14-beta-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-320.14-beta-driver.html

Notebook drivers

http://www.nvidia.com/object/notebook-win8-win7-320.14-beta-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-320.14-beta-driver.html

Comment 82

4 years ago
The problem for me has been solved. I turned on hardware acceleration today and Mozilla did not crash. I am using the same graphic drivers as before (314.22). Before Firefox would also crash with those drivers, but now they don't. I suspect sometime between then and now, Microsoft released an update which fixed the problem. I will keep posted if the same thing occurs during a reboot or graphic driver update.
(Reporter)

Comment 83

4 years ago
There was Patch Tuesday this week, so MS released several updates. Would be nice to know which one might have helped here, and if it helped globally with this or just for you.

Comment 84

4 years ago
(In reply to grkmanga49 from comment #82)
> I turned on hardware acceleration today and Mozilla did not crash.
Firefox needs to be restarted once the checkbox has been checked. Did you do that?

> I suspect sometime between then and now, Microsoft released an update
> which fixed the problem.
There hasn't been any patches regarding D3D11.dll. The latest version is still 6.2.9200.16492 from January 2013. In addition, I see no decreasing tendency for those crashes: https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/20.0.1

Comment 85

4 years ago
Here are correlations from May 10 in 20.0.1:
  RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*)|EXCEPTION_ACCESS_VIOLATION_EXEC (466 crashes)
    100% (466/466) vs.   1% (1229/136061) atkdx11disp.dll (7.14.10.305)
  CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*)|EXCEPTION_ACCESS_VIOLATION_EXEC (200 crashes)
    100% (199/200) vs.   1% (1229/136061) atkdx11disp.dll (7.14.10.305)
  RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*)|EXCEPTION_ACCESS_VIOLATION_WRITE (19 crashes)
    100% (19/19) vs.   1% (1229/136061) atkdx11disp.dll (7.14.10.305)

It's likely a duplicate of bug 819028.
Summary: [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) → [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) on Asus computers

Comment 86

4 years ago
*sigh*

I have two new crash types:

Firefox 21.0 Crash Report [@ RtlpAllocateHeap | RtlpAllocateHeap | __ClientAddFontResourceW ]
@ https://crash-stats.mozilla.com/report/index/647c3062-bbf1-48d9-833b-958aa2130522

Firefox 21.0 Crash Report [@ RtlpAllocateHeap | RtlpAllocateHeap | _imp_load__GetExplicitEntriesFromAclW ]
@ https://crash-stats.mozilla.com/report/index/5c8c922e-59d0-4dfc-8f12-5ff5b2130522

Comment 87

4 years ago
Nvidia released GeForce 320.18 WHQL drivers.

http://www.nvidia.com/object/win8-win7-winvista-32bit-320.18-whql-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-320.18-whql-driver.html

Notebook drivers
http://www.nvidia.com/object/notebook-win8-win7-320.18-whql-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-320.18-whql-driver.html

Comment 88

4 years ago
MS has released an update, http://support.microsoft.com/kb/2834140 which updates d3d11.dll, this might or might not fix the various issues related to KB2670838 update.

Comment 89

4 years ago
Updated my system with the new win update 2834140 and the the lastest Geforce 320.18, but firefox still crash on my system. Running Nvidia Geforce GTX 570
https://crash-stats.mozilla.com/report/index/bp-93231038-0134-47e6-8a19-3a8162130613

Comment 90

4 years ago
Same for me (ASUS AMD Radeon EAH6770 DC/G/2DI/1GD5)

https://crash-stats.mozilla.com/report/index/74a026fa-8a5a-446d-8667-75b992130613

This sucks. :-(

Comment 91

4 years ago
Renaming per bug 819028 comment 37.
Summary: [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) on Asus computers → [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838) with Asus Gamer OSD

Comment 92

4 years ago
The issue is also resolved for me by uninstalling Gamer OSD. Thanks.

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
Keywords: steps-wanted → reproducible

Updated

4 years ago
Duplicate of this bug: 819028

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
(Reporter)

Comment 94

4 years ago
It looks like volume of this is dropping on release since MS Patch Tuesday. I will only trust this if the dropping volume persists, though. Seen too much already here.

Comment 95

4 years ago
@Robert

The MS updates made no difference. Uninstalling Gamer OSD worked though.
(Reporter)

Comment 96

4 years ago
(In reply to Glen A. from comment #95)
> The MS updates made no difference. Uninstalling Gamer OSD worked though.

I know that's true for previous updates from MS, but I'm talking specifically about those from this Tuesday, as I'm seeing the crash signatures go down in volume in the stats. That may be some other reason as well, though.

Comment 97

4 years ago
Yes, I was referring to the latest updates as well. After applying them, I re-enabled hardware acceleration, and Firefox continued to crash (see https://crash-stats.mozilla.com/report/index/2cdb5834-d902-4e33-b250-2913b2130710).
(Reporter)

Comment 98

4 years ago
Thanks. I know why I said I don't trust the trend until it prolongs itself. Even if it's too bad. The question is if the actual bug behind all this lies with Microsoft or ASUS, ore even our code (though I somewhat suspect one of the former, as it only happens on those systems).

Updated

4 years ago
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
(Reporter)

Comment 99

4 years ago
OK, so it actually looks like the "RtlpAllocateHeap | CContext::PerformAmortizedRenderOperations()" is taking over a major part of the volume that other signatures have lost. This might overall not be a decrease after all - probably as expected.

I start thinking the actual bug might lie with ASUS, we might want to contact them.

Comment 100

4 years ago
Seeking a connection on the Asus team.
(In reply to Christopher Arnold from comment #100)
> Seeking a connection on the Asus team.

Following up in email to find out if we got a contact.

Comment 102

4 years ago
We connected to Asus BD team.  I'll cc you in.
What's the current status from Asus's side? This has jumped 21 positions to #10 in the Firefox 25.0a2 topcrash report.

Comment 104

4 years ago
We're checking in with them to see where they are on this.
It's a bit early days but this is currently the #1 top crash in 25 Beta.
https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/25.0b1

Comment 106

4 years ago
Thanks Anthony.  Asus is at a loss on what they can do on this front.  If anyone on our team knows specific course of action to recommend, it would be helpful.
Based on the most recent correlations I'm not sure this qualifies as a topcrash any longer. Someone more experienced should have a look at the numbers in aggregate to make sure. If I'm right I'm not sure we should worry about this any longer.

RtlpAllocateHeap
> 24.0   #158 0.07%
> 25.0b  non-existent
> 26.0a2 non-existent
> 27.0a1 #212 0.07%

CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*)
> 24.0   #31  0.26%
> 25.0b  #66  0.14%
> 26.0a2 #68  0.16%
> 27.0a1 #291 0.05%

RtlpAllocateHeap | TOptImmediateContext::AcquireDevCtxIfaceNoSync()
> 24.0   #45  0.19%
> 25.0b  #38  0.21%
> 26.0a2 #94  0.12%
> 27.0a1 #35  0.30%

The following signatures no longer exist in our top-300 report:
> [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlFreeMemoryBlockLookaside | d3d11.dll@0x8430c ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlpCallQueryRegistryRoutine | d3d11.dll@0x7c20 ]
> [@ RtlpAllocateHeap | d3d11.dll@0x7c20 ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlUlonglongByteSwap | d3d11.dll@0x7c20 ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | zzz_AsmCodeRange_Begin | d3d11.dll@0x8430c ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | __RtlConvertUlongToLargeInteger | d3d11.dll@0x8430c ]
> [@ RtlpAllocateHeap | RtlpAllocateHeap | SdbInitDatabase ]
> [@ d3d11.dll@0x7c1f ]
> [@ d3d11.dll@0x7c20 ]
> [@ d3d11.dll@0xe6314 ]
> [@ CResource<ID3D11Resource>::InvalidAlignment(D3D11_BOX const*)]
> [@ RtlpAllocateHeap | SdbInitDatabase ]
> [@ RtlpAllocateHeap | CContext::PerformAmortizedRenderOperations()]
status-firefox20: affected → wontfix
status-firefox21: affected → wontfix
status-firefox22: affected → wontfix
status-firefox23: affected → wontfix
status-firefox26: --- → affected
status-firefox27: --- → affected
(Reporter)

Comment 108

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #107)
> Based on the most recent correlations I'm not sure this qualifies as a
> topcrash any longer. Someone more experienced should have a look at the
> numbers in aggregate to make sure. If I'm right I'm not sure we should worry
> about this any longer.

This is a crash in Microsoft libraries and we are currently missing symbols for the recent round of their updates, I wouldn't judge this before we get those symbols in place.
Oh right, thanks for pointing that out.
Since this appears to be unactionable from both Asus and our viewpoint can we just pull the trigger and flag this as unactionable?
(Assignee)

Comment 111

4 years ago
Pull what trigger? If this is still a topcrash, we need to track it and get it fixed somehow or another; giving up isn't really an option. I don't understand what happened with ASUS: are they claiming that they don't understand the bug report here, or that the steps to reproduce are insufficient, or something else?
Flags: needinfo?(carnold)

Comment 112

4 years ago
Asus does not know what they can do about this.  If there are specific fixes we believe they can try, I will ask my contact there to have another go.
Flags: needinfo?(carnold)
(Assignee)

Comment 113

4 years ago
We don't have any way of suggesting specific engineering fixes to them: by all appearances, their drivers are causing memory corruption which then causes Windows to crash. We need them to apply engineering to investigate the problem.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #111)
> Pull what trigger? 

Sorry, I meant to say have we hit the point with this bug which enables us to add the [unactionable] whiteboard tag.
(Assignee)

Comment 115

4 years ago
What does that tag actually change?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #115)
> What does that tag actually change?

It doesn't change anything apart from the fact that it lets RelMan track bugs which we know to be unactionable on our end.

Comment 117

4 years ago
Asus has discontinued support of Gamer OSD.  As of 2012, there is no bundling of Gamer OSD in Asus products.
(In reply to Christopher Arnold from comment #117)
> Asus has discontinued support of Gamer OSD.  As of 2012, there is no
> bundling of Gamer OSD in Asus products.

Are they doing anything on their end to encourage removal of this product by existing users? Perhaps through a driver update?
(Assignee)

Comment 119

4 years ago
Can we already tell from a crash report whether Gamer OSD is installed? If not, we should add it to crash annotations, and inform users to uninstall via the support classification system which we're building (email and web).
I don't know if that info is in the crash report. However based on current rankings this no longer qualifies as a topcrash:

 * Release: #48
 * Beta:    #37
 * Aurora:  #30
 * Nightly: #100

We might want to continue to monitor over the coming weeks to see if this continues to drop off.
Keywords: topcrash

Comment 121

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #118)
> (In reply to Christopher Arnold from comment #117)
> > Asus has discontinued support of Gamer OSD.  As of 2012, there is no
> > bundling of Gamer OSD in Asus products.
> 
> Are they doing anything on their end to encourage removal of this product by
> existing users? Perhaps through a driver update?

They don't have any ongoing support or driver updating for old machines.
(Assignee)

Comment 122

4 years ago
Through some searching, it appears that the DLL which is causing the crashes is atkdx11disp.dll.  I would like to DLL-block this and see whether this fixes this category of crash completely.
Assignee: milan → benjamin
(Assignee)

Comment 123

4 years ago
Created attachment 818536 [details] [diff] [review]
bug812683-asusgamerosd
Attachment #818536 - Flags: review?(jmuizelaar)
(Assignee)

Updated

4 years ago
Depends on: 927944
[@ ntdll.dll@0x33ca4] is showing up high on the topcrashers for Firefox 25b (#10) and appears to be highly correlated to a Windows update (based on comments), and atkdx11disp.dll and d3d11.dll based on correlation reports. I assume this signature is another manifestation of *this* crash.

FWIW, it's currently 2nd on the Firefox 25 explosiveness report:
https://crash-analysis.mozilla.com/rkaiser/2013-10-16/2013-10-16.firefox.25.explosiveness.html
Crash Signature: [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip; → [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c1f ] [@ RtlpAllocateHeap | RtlpAllocateHeap | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAllocateHeap | RtlAllocateMemoryBlockLookaside | d3d11.dll@0x7c20 ] [@ RtlpAllocateHeap | RtlpAlloc&hellip;
Attachment #818536 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 125

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/74252b21fdac
Target Milestone: --- → mozilla27
https://hg.mozilla.org/mozilla-central/rev/74252b21fdac
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 127

4 years ago
I have verified that these crashes went away on nightly as of the 20131022030202 build.
Status: RESOLVED → VERIFIED
Target Milestone: mozilla27 → ---
(Assignee)

Comment 128

4 years ago
Comment on attachment 818536 [details] [diff] [review]
bug812683-asusgamerosd

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unsupported external software
User impact if declined: #3/4 topcrasher
Testing completed (on m-c, etc.): verified via crash-stats, no side-effects found
Risk to taking this patch (and alternatives if risky): it's possible that blocking this DLL could cause some other piece of code to crash, but we haven't seen that in nightly crash-stats
String or IDL/UUID changes made by this patch: none
Attachment #818536 - Flags: approval-mozilla-beta?
status-firefox27: affected → fixed
Comment on attachment 818536 [details] [diff] [review]
bug812683-asusgamerosd

Approving for FF26 beta uplift
Attachment #818536 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/7832c5ffcb18
status-firefox24: affected → wontfix
status-firefox25: affected → wontfix
status-firefox26: affected → fixed
Target Milestone: --- → mozilla27
Automated merge from beta.
https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/7832c5ffcb18
status-b2g-v1.2: --- → fixed

Comment 132

4 years ago
I hit this when I installed IE 10 and had to use system restore.  Tonight I installed IE 11 and reproduced the crash in Seamonkey 2.22 and Firefox 24.0.  I could not find how to disable hw acceleration in Seamonkey but did in Firefox in safe mode and that allowed it to run.  I then saw the comments about Asus Gamer OSD.  Instead of going back to a restore point I uninstalled Gamer OSD.  After, I found Seamonkey was able to run without crashing.  It then reenabled hw acceleration in Firefox and it also is able to run.  Just wanted to give y'all my data point.  Thanks!
Blocks: 942776
(Reporter)

Updated

4 years ago
Duplicate of this bug: 942776
You need to log in before you can comment on or make changes to this bug.