[PDF.js] unable to load pdf files, and crashes content on browser

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: fabrice)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [Browser][TR 11-15-12], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 682693 [details]
screenshot

When trying to load a pdf file on sites within the browser, the content will try to load, then launch PDF viewer, and immediately crash the content within Browser.

Reproduced on two different sites that host pdf data

See logcat and screenshot

Repro:
1) install 11-16-2012 nightly unagi build
** buildID = 20121116070715
2) launch browser, and visit a site with pdf images (eg. www.irs.gov, www.fda.gov)
3) click the pdf image
4) verify PDF Viewer tries to load, then crashes the content within the browser.  The PDF never fails to open.

Expected:
- PDF Loads in pdf viewer, no browser crash

Actual:
- browser content crashes, pdf never launches
(Reporter)

Comment 1

6 years ago
Created attachment 682694 [details]
logcat

snippet of log:
11-16 19:09:41.420: E/GeckoConsole(10274): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
11-16 19:09:41.830: I/Gecko(10274): [Parent 10274] WARNING: pipe error (114): Connection reset by peer: file /data/jenkins/jobs/build-unagi-stable/workspace/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 421
11-16 19:09:41.830: I/Gecko(10274): [Parent 10274] WARNING: pipe error (116): Connection reset by peer: file /data/jenkins/jobs/build-unagi-stable/workspace/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 421
11-16 19:09:44.773: E/profiler(11524): Registering start signal
11-16 19:09:46.495: I/Gecko(10274): [Parent 10274] WARNING: pipe error (114): Connection reset by peer: file /data/jenkins/jobs/build-unagi-stable/workspace/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 421
11-16 19:09:46.505: I/Gecko(10274): [Parent 10274] WARNING: pipe error (116): Connection reset by peer: file /data/jenkins/jobs/build-unagi-stable/workspace/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 421
blocking-basecamp: ? → +
Priority: -- → P2
Sounds not a pdf.js bug.
Component: Gaia::Browser → General
Fabrice do you have some free cycles to look at it?

I wonder if this could be related to the new MozActivity restrictions regarding user input / trusted event (bug 794407)
(Assignee)

Comment 4

6 years ago
(In reply to Vivien Nicolas (:vingtetun) from comment #3)
> Fabrice do you have some free cycles to look at it?
> 
> I wonder if this could be related to the new MozActivity restrictions
> regarding user input / trusted event (bug 794407)

yes...
Assignee: nobody → fabrice
(Assignee)

Comment 5

6 years ago
I filed Bug 813828 to fix a general issue with web activities in chrome land. but I feel this bug is a different issue.

I could not reproduce a crash, but even with the fix in bug 813828 the pdf viewer is not showing up.

Comment 6

6 years ago
Marking for C2, given this meets the criteria of known P1/P2 blocking-basecamp+ bugs at the end of C1.
Target Milestone: --- → B2G C2 (20nov-10dec)

Updated

6 years ago
Whiteboard: [Browser][TR 11-15-12]
(Assignee)

Comment 7

6 years ago
With the fix in bug 813828 I can successfully load pdf documents again. I tried the first few of the request "pdf sample" in Bing and can't reproduce a crash. Tony, if you have urls that I can use to repro your crases, please reopen.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

6 years ago
I'm not crashing anymore, but pdf viewer doesnt load anymore.  i'll file a new bug for this.
You need to log in before you can comment on or make changes to this bug.