Using configure flag --with-jpeg=no

RESOLVED FIXED in mozilla0.9.9

Status

SeaMonkey
Build Config
P3
normal
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: MichaelWright9, Assigned: cls)

Tracking

Trunk
mozilla0.9.9
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Built with the flag --with-jpeg=no so that the system JPEG shared library 
would not be used (mozilla 0.9). This means the imgjpeg library uses the mozjpeg 
library. The mozjpeg library should be made as a static library not shared.
(Reporter)

Comment 1

17 years ago
I think the --with-jpeg=no flag should work like the --with-png=no flag. When 
the --with-png=no flag is used, mozilla builds/links with the static library 
libmozpng.a.
Summary: Using confiure flag --with-jpeg=no → Using configure flag --with-jpeg=no

Comment 2

17 years ago
over to build
Assignee: pavlov → cls
Component: ImageLib → Build Config
QA Contact: tpreston → granrose
(Assignee)

Comment 3

17 years ago
For the most part, I wouldn't care except it looks like we link jpeg against 3
different libs which means symbol duplication.  Png is really only used in one
place (either libimg's pngcom or libpr0n's png decoder).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Aren't the other uses in the older image decoders (or have i got my module names 
confused again)?  So are they an issue?

You can avoid some the symbol duplication by using the configure option to roll a 
few components into one when using the static lib option.  Or do we need to 
support using the non system version as both shared and static?

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 5

17 years ago
jpeg is linked twice in both libimg & libpr0n (and once in xpfe/bootstrap for
static builds).  Once in the jpeg decoder and once in the mng decoder. With the
static build landing, we inadvertently made jpeg build static always so I'll
just leave it and close this out.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 114679 has been marked as a duplicate of this bug. ***
Tor's reopening this issue since mng is being reintroduced into the build RSN.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9.3 → mozilla0.9.9
Marking fixed again.  If anyone really thinks that the 120k (yes, I measured it)
is worth arguing about at this point in the game, feel free to reopen.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.