If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WebGL Conformance Test 1.0.1 - FAIL gl.getContextAttributes() should be null. Was [object Object]

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: MrX1980, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Steps to reproduce:
a) use Firefox Nightly 19.0a1 (Release, Beta and Aurora is working)
b) webgl.prefer-native-gl;false
c) open the WebGL Conformance Test 1.0.1
d) FAIL gl.getContextAttributes() should be null. Was [object Object]

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
browser.startup.homepage_override.buildID: 20121117030747 (older builds too)

WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4670 AGP)
or
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Ti)
https://groups.google.com/forum/?fromgroups#!topic/webgl-driver-testing/UhiZNxTgZ90

Because "webgl.prefer-native-gl;true" is working, could it be an ANGLE bug/regression ?
(Reporter)

Comment 1

5 years ago
It is working again with release (v17.0.1), beta (v18b6), aurora (v19) and nightly (v20)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.