remove partial download

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

SeaMonkey 2.13 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:16.0) Gecko/20121026 Firefox/16.0 SeaMonkey/2.13.2
Build ID: 20121026205451

Steps to reproduce:

Put seamonkey to a page with a PDF download, example:
http://schneider.ncifcrf.gov/papers/logo/
start the download by, for example clicking on "PDF version of the paper logopaper."
A small window pops up (on the Mac OS X 10.6.8).  Instead of clicking to Save, click Cancel.


Actual results:

At the moment that the small window appears, a file with a random string
followed by a period, the file type, a period and 'part' appears in the target directory.  Examples:

upeRtDw5.pdf.part 
ZhiOdHY5.pdf.part   
W3fZ6jQC.pdf.part 

These files are empty (contain 0 bytes).
When one clicks 'Cancel',
the small window disappears.  The 'part' file remains.  
The user has to remove the empty files by hand.



Expected results:

The 'part' file should be removed when one does a Cancel or it should not have been created until
the person committed to the download.

Comment 1

5 years ago
DUP of this ? Bug 420355 - residual .part file when I cancel a download from Save As dialog
(Reporter)

Comment 2

5 years ago
Yes, it does look like a duplicate of Bug 420355.
However, I tested it with a 174 MB file just now and the .part file disappeared
as it should!  So is the bug solved and Bug 420355 isn't up to date?

Comment 3

3 years ago
Resolved per Comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.