Closed Bug 812853 Opened 7 years ago Closed 5 years ago

"XML Parsing Error: unexpected parser state" on netError.xhtml

Categories

(Core :: Networking: Cache, defect)

18 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox18 - verified
firefox19 - verified
firefox20 --- verified

People

(Reporter: alice0775, Assigned: michal)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

http://hg.mozilla.org/mozilla-central/rev/9a6d708faf3f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121117030747

Reproducible: almost always

Steps to reproduced:
  1. Delete startupCache. i.e. Delete C:\Users\xxxxxxx\AppData\Local\Mozilla\Firefox\Profiles\yyyyyy.profilenname, if exist
  2. Start browser, Clear Cache
  3. Restart browser
  4. Wait for 5 min
  5. Open http://speed.googlefiber.net/ in new tab(background)
  6. After 90sec, "! Problem loading page" may be displaied in the tab as expected, Close the tab
  7. Open http://speed.googlefiber.net/ in new tab(background) again
  8. After 90sec, "! http://speed.googlefiber.net/"  is displaied on the tab


Actual results:

XML Parsing Error: unexpected parser state
Location: jar:file:///L:/trunk/2012/09/firefox%20inbound%2006-Sep-2012%200756%20Bug%20405407%20Merge%20nsDiskCacheStreamIO/omni.ja!/chrome/toolkit/content/global/netError.xhtml
Line Number 311, Column 58:        <div id="ed_netInterrupt">&netInterrupt.longDesc;</div>

Expected results:
  "Problem loading page"
  The connection was reset
  The connection to the server was reset while the page was loading.



Regression window(cached m-c)
Good;
http://hg.mozilla.org/mozilla-central/rev/9677eb19a6a5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120906054802
Bad:
http://hg.mozilla.org/mozilla-central/rev/233441ff53af
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120906173834
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9677eb19a6a5&tochange=233441ff53af


Regression window(cached m-i)
Good;
http://hg.mozilla.org/integration/mozilla-inbound/rev/48ae6c0a626c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120906062901
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/42777635165a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120906071302
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=48ae6c0a626c&tochange=42777635165a

Suspected:
c12db325f863	Josh Aas — Bug 405407: Merge nsDiskCacheStreamIO and nsDiskCacheStreamOutput. Patch originally by Alfred Kayser, updated by Josh Aas, final fix from Michal Novotny. r=michal
Attached file http log
We should probably just back my patch out unless we can find a fix very quickly.
Assignee: nobody → michal.novotny
It seems to be fixed with STR in Nightly20.a2(hourly build) by back out Bug 405407.
http://hg.mozilla.org/mozilla-central/rev/a9d59073400b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 ID:20121120065452

However, "XML Parsing Error: unexpected parser state" happens at the first load(Step5,6) sometimes and should be Bug 569229 .
Depends on: 569229
(In reply to Josh Aas (Mozilla Corporation) from comment #2)
> We should probably just back my patch out unless we can find a fix very
> quickly.

The STR in comment 0 don't really make the user impact clear. Do we think this will be a common user experience outside of these STR?
bug 405407 is being backed out of Aurora/Beta, no need to track this specifically.
To be retested with 814010.
Depends on: 814010
This should be resolved with the backout of 405407.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Alice, could you confirm this is also fixed in Firefox 18 beta2 and F19?
I can't reproduce this on Windows 7.
 
(In reply to Alice0775 White from comment #3)
> It seems to be fixed with STR in Nightly20.a2(hourly build) by back out Bug
> 405407.
> http://hg.mozilla.org/mozilla-central/rev/a9d59073400b
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0
> ID:20121120065452
> 
> However, "XML Parsing Error: unexpected parser state" happens at the first
> load(Step5,6) sometimes and should be Bug 569229 .
I cannot  reproduce the problem with  STR comment#0 in 18beta and Aurora19.0a2 any more.
http://hg.mozilla.org/releases/mozilla-beta/rev/6eb5edeb9f52
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 ID:20121128060531
http://hg.mozilla.org/releases/mozilla-aurora/rev/c1e60736791c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20121203 Firefox/19.0 ID:20121203042014

And sometimes as same as Nightly20.0a1, "XML Parsing Error: unexpected parser state" happens at the first load(Step5,6).
Thank you! I'll mark this as verified.
Status: RESOLVED → VERIFIED
I just ran into this in a Feb-25 Nightly:

XML Parsing Error: unexpected parser state
Location: jar:file:///C:/Program%20Files%20(x86)/Nightly/omni.ja!/chrome/toolkit/content/global/netError.xhtml
Line Number 311, Column 58:        <div id="ed_netInterrupt">&netInterrupt.longDesc;</div>
---------------------------------------------------------^

I don't have good STR, but there's still an underlying intermittent issue :/
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
In Bug 725993 there is a comment that possibly antivirus scanner may be involved:
"I wonder if users are seeing these freezes caused by this due to disk activity on their systems by virus scanners (some people even run multiple scanners!) or the OS's search indexing service (SearchIndexer.exe) misbehaving.".

In almost all of the diskcache write crashes there is a thread with:
4 	xul.dll 	nsDownloadScannerWatchdog::WatchdogThread 	toolkit/components/downloads/nsDownloadScanner.cpp:669
Also netError.xhtml is not loaded through the diskcache (or cache at all), so I am wondering how this netError.xhtml can be related to the diskCache?
Duplicate of this bug: 866071
(In reply to Vladimir Vukicevic [:vlad] [:vladv] from comment #11)
> I just ran into this in a Feb-25 Nightly:

vladimir, about the comment 12, any thought?
Flags: needinfo?(vladimir)
I have not seen this in a loooong while.  So we can probably call this fixed.
Status: REOPENED → RESOLVED
Closed: 7 years ago5 years ago
Flags: needinfo?(vladimir)
Resolution: --- → WORKSFORME
(In reply to Vladimir Vukicevic [:vlad] [:vladv] from comment #18)
> I have not seen this in a loooong while.  So we can probably call this fixed.

I think this to WORKSFORME is incorrect, because the "Tracking Flags" existence.
You need to log in before you can comment on or make changes to this bug.