Other Firefox browser windows routinely pop in front when interacting with the currently active browser window

RESOLVED DUPLICATE of bug 768802

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 768802
6 years ago
4 years ago

People

(Reporter: IU, Unassigned)

Tracking

Trunk
All
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
On windows 8, browser windows will occasionally pop in front when performing an action with another window.  I have seen this issue on rare occasion on XP and Windows 7, but the issue is very prevalent on Windows 8 and is reproducible using the following STR:

1. Make sure you're using Windows 8 on actual hardware and you are performing the following actions directly at the machine and not though any remote connection.  I cannot vouch for reproducibility using any other configuration.
2. Launch Firefox with a new profile
3. Visit groklaw.net (other sites would do, but stick with this for this STR)
4. Click the Firefox button and choose History --> Show All History
5. Make sure the Library dialog is over the Firefox window
6. Search history for groklaw
7. Middle-click the groklaw.net entry to open in a new tab
8. On the very right-hand side of the Groklaw site, click on the news picks link titled starting with "Print Subscribe Share/Save..."
9. At this point you should notice that the Library dialog pops back in front.

This STR is just and example to help identify and fix this issue.  It happens in many other ways while browsing the Internet; however, this is STR represents the most consistent way I have been able to reproduce it.
(Reporter)

Comment 1

6 years ago
Note: I am using 32-bit Firefox m-c nightly build.  That is the build this bug is about.
My STR from dupe bug #815054

>1. Open Nightly
>2. Open Library
>3. Close Nightly browse window, so only Library will be opened
>4. Start opening some bookmarks from Library
>5. and try normally browse the web with Library window in background
>
>in near time you will see that Library window will steal focus
>and will go to first plan



Oddly I can't reproduce it on 64bit build or it happens very rarely.
(Reporter)

Comment 4

6 years ago
This bug is not about 64-bit Firefox.  Only my operating platform is 64-bit.  I'm changing "Platform" to "All" to minimize the confusion.
Hardware: x86_64 → All
Yep, I also use 32bit build of Nightly now on Windows 7 64bit. I'm just saying that I was using earlier a 64bit Nightly and oddly it didn't have this issue.
Any ideas what can be causing this bug? For me it happens randomly even with only 2 windows without Library window.

@ Marco Bonardo [:mak] - Can you reproduce it? or we need to get some profile, better STR or etc...
(Reporter)

Comment 7

6 years ago
The Library was used, in presenting an STR, because it is a simple and consistent way for anyone to reproduce this bug.  It affects all Firefox Windows and I experience this frequently and daily.  And yes it is really annoying.

If Mozilla fixes the Library scenario detailed above, that should fix all other cases.
(Reporter)

Comment 8

6 years ago
This issue is also being reported on the Mozilla Support forum: http://support.mozilla.org/en-US/questions/942312?esab=a&s=in+front&r=6&as=s

Comment 9

6 years ago
This bug annoys me as well. One thing I've noticed (in case it helps narrow down the problem) is that it doesn't occur for me if I turn-off JavaScript.

Comment 10

6 years ago
Also disabling the shockwave flash plugin seems to stop it happening as well.
Can a profiling help here or what can we do more to diagnose it further?
Flags: needinfo?(mak77)
could be related to bug 833048 and bug 768802
I don't think profiling may help much unless in the profiling stack you find some calls to plug-ins or focus.
Flags: needinfo?(mak77)
Thanks for info. Now this bug looks like a duplicate of bug #768802.
Should we mark it as one?
Flags: needinfo?(fehe)
(Reporter)

Comment 14

5 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #13)
> Thanks for info. Now this bug looks like a duplicate of bug #768802.
> Should we mark it as one?

I'm not so sure.  While a page with flash does significantly increase reproducibility, this is not always the case.

As such, I would prefer leaving them as separate reports.
Flags: needinfo?(fehe)

Comment 15

5 years ago
This is happening on my Windows 7 OS. A new pop-up window appears after using Firefox/Mozilla browser. Just suddenly started to happen in the last week or so.

Comment 16

4 years ago
May be related to bug #848116

Get this regularly on Windows7.
Currently see this on 64 bit nightly.
Last year was happening regularly on 32bit Aurora.
(Reporter)

Comment 17

4 years ago
Fixed by bug 768802
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 768802
You need to log in before you can comment on or make changes to this bug.