All time-consuming tasks freeze the whole UI until complete

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: matteosistisette, Unassigned)

Tracking

({perf})

16 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

Steps to reproduce:

Any time-consuming task like for example:
- copy or move a large number of messages
- save a message that has big attachments
- saving big messages to disk just after downloading


Actual results:

The whole UI freezes. In some cases it even shows up the popup "A script is making this page unresponsive".

It looks like as if everything in TB was implemented as a monolythic one-thread program where every time consuming task blocks the application completely. (only exception seems to be network communication with the server, well, if even that was blocking it would be embarassing).



Expected results:

Time-consuming tasks should be done in the background or anyway in a separate thread from the UI, which must be always perfectly responsive no matter what the program is doing.

Also, when some time consuming task is taking place, a progress bar or at least a "busy" animation must be shown. But any other task that doesn't depend on it must be allowed to be done, or at the very least, the UI must be responsive (i.e. it can't freeze with a button in the pressed state until the operation is complete!!)
(Reporter)

Updated

6 years ago
Severity: normal → critical
> Any time-consuming task like for example:
A. copy or move a large number of messages
B. save a message that has big attachments
C. saving big messages to disk just after downloading

A is a known issue, so a duplicate report we don't need to worry about.

B and C are also likely to be duplicates. Please look for similar bug reports with search https://bugzilla.mozilla.org/query.cgi

In our bug system, reports are to cover one issue per bu. So as written this is invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: perf
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.