The default bug view has changed. See this FAQ.

[Dialer] Dialer shows with screen after tap on button call, then dialer is broken

VERIFIED FIXED in B2G C1 (to 19nov)

Status

Firefox OS
Gaia
P1
blocker
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: scravag, Unassigned)

Tracking

({dogfood, smoketest, unagi})

unspecified
B2G C1 (to 19nov)
ARM
Gonk (Firefox OS)
dogfood, smoketest, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
gecko-aurora: 13365a46ce7d
gaia: bd284fb5fdc540865a720e3a1394a37c487a49f9

1 - Open Dialer
2 - Compose a phone number
3 - Tap Call button

Expected:
Call occurs
screen shows dialer comm screen

Actual
Call occurs
Dialer shows white screen
* Quit dialer using long tap home then quit
-> A green bar appears on the top of the Homescreen. The green bar is persistent.
-> When launching apps, green bar remains
-> When launching Dialer, the Dialer is broker, unusable.
(Reporter)

Updated

4 years ago
Severity: normal → blocker
blocking-basecamp: --- → +
Keywords: dogfood, smoketest, unagi
Priority: -- → P1
Target Milestone: --- → B2G C1 (to 19nov)
As German pointed on IRC, the regression comes from:

https://github.com/mozilla-b2g/gaia/commit/bd284fb5fdc540865a720e3a1394a37c487a49f9

Should I go ahead and make a nightly branch merge with this commit backouted?
Created attachment 683048 [details]
PR 6489

The root cause is, assigning wrong value to mozAudioChannelType.
The strings acceptable now is 'normal', 'content', 'alarm', 'notification'. But
'ring' channel is not supported yet.
Attachment #683048 - Flags: review?(etienne)
(In reply to Alive Kuo [:alive] from comment #2)
> Created attachment 683048 [details]
> PR 6489
> 
> The root cause is, assigning wrong value to mozAudioChannelType.
> The strings acceptable now is 'normal', 'content', 'alarm', 'notification'.
> But
> 'ring' channel is not supported yet.

Actually, according to 805333, 'ringer' has been added in the list but not really supported yet, according to @marco
Attachment #683048 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/pull/6489
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 5

4 years ago
Verified fixed on Unagi Build 20121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.