Unable to type Hebrew characters

VERIFIED DUPLICATE of bug 74088

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 74088
17 years ago
17 years ago

People

(Reporter: Tzafrir Cohen, Assigned: Frank Tang)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When LANG is set to 'he', I am unable to type Hebrew characters. Hebrew
characters I type show up as accented latin1 characters. It seems to be that
those are characters with the same value of the keysym, when its upper byte is
stripped.

I have verified that key presses indeed send the correct keysyms (Hebrew_*).
When I run mozilla with a different locale, the Hebrew letters I type show up
properly.
->i18n
Assignee: pchen → nhotta
Component: XP Apps → Internationalization
QA Contact: sairuh → andreasb

Comment 2

17 years ago
Reassign to ftang.
Assignee: nhotta → ftang
(Assignee)

Comment 3

17 years ago
set a break point at keysym2ucs (widget/src/gtk/keysym2ucs.c, line 848 ) and 
318 PRUint32 nsConvertCharCodeToUnicode(GdkEventKey* aGEK)
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk/nsGtkEventHandler.cpp#370
to see what happen here. 
tajima, katakai- any one in your team can help this one?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Is this a dup of (or at least related to) bug 56947?
Also compare bug 74088

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 74088 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified as dupe, please reopen in case someone disagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.