Download Manager does not show progress in Private Browsing mode anymore

RESOLVED DUPLICATE of bug 812633

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 812633
5 years ago
5 years ago

People

(Reporter: Frank, Unassigned)

Tracking

({regression})

19 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 683063 [details]
0886_1911.2012_1327.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121118030713

Steps to reproduce:

Active Private Browsing and download files using the built in download manager 


Actual results:

Nightly does not show the animation of the download "flying" into the manager, nor does it show the download progress, nor are you able to cancel the download

Download panel only says "Starting..."


Expected results:

Downloads should work as they do in "not- private mode", the animation should be the same, and even more should the download progress be displayed
Component: Untriaged → Downloads Panel

Updated

5 years ago
Blocks: 747422
could be fallback from the recent per-window pb changes to the downloads backend
Last good nightly: 2012-11-16
First bad nightly: 2012-11-17

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58ebb638a7ea&tochan
ge=9a6d708faf3f

suspected bug 722859 and very likely a dupe of bug 812627 (but this is not save as)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
does it work properly in the old DM window?
(In reply to Marco Bonardo [:mak] from comment #3)
> does it work properly in the old DM window?

No, the DM shows the same symptoms
ok, so this should be tracked, unless we figure bug 812627 fixes it, it's a bad regression.
Blocks: 722859
tracking-firefox19: --- → ?

Updated

5 years ago
Component: Downloads Panel → Download Manager
Product: Firefox → Toolkit

Updated

5 years ago
Summary: Nightly: active Private Mode - Download panel does not show progress → Download Manager does not show progress in Private Browsing mode anymore

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812633
I assume Josh verified bug 812633 fixes this, so this doesn't need to be tracked anymore.
tracking-firefox19: ? → ---
You need to log in before you can comment on or make changes to this bug.